FORUMS

PSA: You Can Optimize Your Note 4’s Recents Menu & RAM

The Note 4 never had the fastest Recents Menu, and despite its 3GB of RAM, … more

XDA Picks: Best Apps of the Week (July 25 – Aug 1)

Apps are at the front and center of any smartphone experience, and with over a … more

Voices Of XDA: Orbiting The Earth With Android

Editor’s note: This week’s feature has been written by forum … more

CloudPlayer: DIY HiFi Music Streaming Solution

In our Helpful Guide to Music Streaming Services, we mentioned several different services … more

[GUIDE][PSA] Google Play Services battery drain fix

21,480 posts
Thanks Meter: 10,741
 
By Heisenberg, Forum Moderator on 30th July 2014, 08:09 AM
Post Reply Subscribe to Thread Email Thread
If you're running a recent CM based or aosp ROM you've most likely encountered some pretty severe battery drain from Google Play Services (or Android OS as it sometimes shows up as). Below is a procedure that will halt the battery drain, but will not affect the running of your device.

Enter Privacy Guard through Settings/Security or Settings/Privacy, then click Advanced or Show Built-In Apps (depending on which ROM you're running). From here you can select Google Play Services and deny the Wake Up, Keep Awake, and Auto-Start options. Reboot phone. This should drastically reduce the amount of battery that Google Play Services and Android OS consume.



If you're on a ROM that doesn't include Privacy Guard or App Ops as standard you need to take a slightly different approach. Download this:

https://play.google.com/store/apps/d....quickshortcut

Open the app and it should already be in the Activities tab, scroll down to Settings and click on it, that will open up a whole list of different options, scroll down to the App Ops option and click on that, hit the create button at the bottom of the screen.

This is going to add a Settings icon/shortcut to your home screen, click on that and you'll be taken into the secret App Ops section of the settings menu, from there just find Google Play Services and click on it, then disable the Wake Up and Keep Awake options. Reboot phone, no more Google Play Services battery drain.



Please note: If you rely on your location being updated frequently then this method might not be right for you. This method disallows Google Play Services from waking your device every minute to obtain your location and Google Now cards are affected as a result. All other Google services should function normally.


Donate To Me

Transmitted via Bacon
Last edited by Heisenberg; 6th April 2015 at 12:29 PM.
The Following 345 Users Say Thank You to Heisenberg For This Useful Post: [ View ]
 
 
30th July 2014, 10:37 AM |#2  
Senior Member
Flag Viborg Denmark
Thanks Meter: 5
 
More
I can vote for this, I did have massive battery drain from google services, but now, none.
30th July 2014, 10:45 AM |#3  
Heisenberg's Avatar
OP Forum Moderator
Knocking on your door
Thanks Meter: 10,741
 
Donate to Me
More
Glad to help.

Sent via Bacon
The Following 3 Users Say Thank You to Heisenberg For This Useful Post: [ View ]
30th July 2014, 10:49 AM |#4  
EddyOS's Avatar
Recognized Contributor
Flag Liverpool, Merseyside
Thanks Meter: 3,723
 
More
Do you need root access for this?
The Following User Says Thank You to EddyOS For This Useful Post: [ View ]
30th July 2014, 11:12 AM |#5  
Heisenberg's Avatar
OP Forum Moderator
Knocking on your door
Thanks Meter: 10,741
 
Donate to Me
More
Yes. I'll add that information to the OP.

Sent via Bacon
The Following User Says Thank You to Heisenberg For This Useful Post: [ View ]
30th July 2014, 06:27 PM |#6  
Calkulin's Avatar
Recognized Developer
Thanks Meter: 8,859
 
Donate to Me
More
This guide is a little excessive, the biggest battery killer for that app, especially if you use Google Now, is the wake ups permission, so denying just that will fix most of the battery drain. If you want to go the extra mile, denying the keep awake permission also which fix the other minor part and none of these fixes require root

EDIT: Just noticed you said AOSP, which doesn't have the wake up or keep awake permissions to deny IIRC, so what I said only applies to the CM ROMs
Last edited by Calkulin; 30th July 2014 at 06:30 PM.
The Following 10 Users Say Thank You to Calkulin For This Useful Post: [ View ]
30th July 2014, 08:05 PM |#7  
Heisenberg's Avatar
OP Forum Moderator
Knocking on your door
Thanks Meter: 10,741
 
Donate to Me
More
Quote:
Originally Posted by Calkulin

This guide is a little excessive, the biggest battery killer for that app, especially if you use Google Now, is the wake ups permission, so denying just that will fix most of the battery drain. If you want to go the extra mile, denying the keep awake permission also which fix the other minor part and none of these fixes require root

EDIT: Just noticed you said AOSP, which doesn't have the wake up or keep awake permissions to deny IIRC, so what I said only applies to the CM ROMs

While this may seem excessive, the fact is it works. My personal experience was that after changing the things mentioned that don't require root I still had Google Play Services draining my battery. As with anything though, mileage may vary. I'll add a note that the root section may or may not be required.

Forgive me for using a term (AOSP) that most XDA users associate with anything that's CM based. While it may not technically be 100% correct, it seemed to be in keeping with the vernacular used by your average XDA member.

Thanks for your input, I appreciate it.

Sent via Bacon
The Following 8 Users Say Thank You to Heisenberg For This Useful Post: [ View ]
30th July 2014, 08:29 PM |#8  
Senior Member
Thanks Meter: 550
 
More
A much simple process (that doesn't require root) worked for me:

1. I used Privacy Guard to deny Google Services "Wake up," "Keep awake" and "Auto start."

2. Under Settings > Apps > Running I stopped all instances of Google Play services.

They still come back but aren't killing my battery with wakelocks. It seems to accord with what Calkulin said above.
Last edited by CafeKampuchia; 30th July 2014 at 08:31 PM.
The Following 4 Users Say Thank You to CafeKampuchia For This Useful Post: [ View ]
30th July 2014, 08:50 PM |#9  
Junior Member
Thanks Meter: 4
 
More
Thanks a lot, I have done everything in the OP, will report back
The Following User Says Thank You to savahu For This Useful Post: [ View ]
30th July 2014, 08:58 PM |#10  
Heisenberg's Avatar
OP Forum Moderator
Knocking on your door
Thanks Meter: 10,741
 
Donate to Me
More
Quote:
Originally Posted by CafeKampuchia

A much simple process (that doesn't require root) worked for me:

1. I used Privacy Guard to deny Google Services "Wake up," "Keep awake" and "Auto start."

2. Under Settings > Apps > Running I stopped all instances of Google Play services.

They still come back but aren't killing my battery with wakelocks. It seems to accord with what Calkulin said above.

Like I said just above, mileage may vary. It's awesome if doing just that worked for you, but for others it isn't enough for some reason.

Sent via Bacon
The Following User Says Thank You to Heisenberg For This Useful Post: [ View ]
30th July 2014, 11:55 PM |#11  
nfl46's Avatar
Senior Member
Thanks Meter: 168
 
More
Thanks for this. I was trying figure out why I was at 20% today for Google Play Services.

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes