Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,298 Members 42,691 Now Online
XDA Developers Android and Mobile Development Forum

[FIXED] Microphone/Ok Google Low Sensitivity

Tip us?
 
xasthe
Old
#31  
xasthe's Avatar
Junior Member
Thanks Meter 3
Posts: 26
Join Date: May 2011
Location: Vancouver
Quote:
Originally Posted by sabbotage View Post
So is this fixed in the newest CM nightlies? I cant't seem to find it in the changelog, but the patch says it was merged.
I believe it is fixed in the CM nightlies, but if you are or want to run CM 11s then this flash is needed to get normal 'OK, Google' hotword detection.

Otherwise when running the current version of CM 11s, you'll need to yell or hold the microphone very close to your face.
Phone: OnePlus One
Sorry, I have no invites.
ROM: CyanogenMod 11S
Kernel: Stock Kernel
Be nice, everyone was a noob at some point.
 
winner00
Old
#32  
Senior Member
Thanks Meter 1052
Posts: 515
Join Date: Sep 2010
The 2 patch's you need from CM are https://github.com/CyanogenMod/andro...9f5b0c6da50978 and https://github.com/CyanogenMod/andro...0b164878a23aaf.

I modified my mixer_paths.xml to include these 2 patches and all is well. Ok Google is working just fine now.
For all things Carbon, check out our website:[ Carbon Rom | Keep up to date with our nightlies by checking the changelog: Carbon Nightly Changelog

Keep up to date by joining our Google+ community: Team Carbon | +1 us on Google+ Carbon on Google+

Like us on Facebook: CarbonRom Facebook | Download the rom on our site: Carbon Downloads


 
XxKINGxX2580
Old
#33  
XxKINGxX2580's Avatar
Senior Member
Thanks Meter 49
Posts: 216
Join Date: May 2013
Location: Atlanta
Quote:
Originally Posted by Kokorone View Post
After diving into some of the files in the oneplus one, I found some file values that once changed, make the microphone actually strong enough to recognize ok google from an arm's distance away. This is essential for using speakerphone, skype, any recording application, as well as google now. I was tired of having people go WAT ARE YOU SAYING repeatedly.

You will need a rooted Oneplus One with some sort of root explorer.
I used Root Explorer (File Manager) by Speed Software

1. Go to system/etc/mixer_paths.xml
2. Mount system as R/W
3. Open up mixer_paths.xml with Text Editor
4. Scroll close to the bottom of the text, your little scroll position indicator should be about an inch up from the bottom of your screen(no on screen buttons)
5. You will see <!-- Analog input devices --> and a bunch of text underneath.
6. I wasn't entirely sure which mic would make this work so I changed the <path name+"main-mic"> value from 84 to 100. (Play around with the value until you find a sweet spot.) IF YOU GET ENVIRONMENTAL MICROPHONE INTERFERENCE, TRY TURNING THE VALUES BACK DOWN A BIT.
7. Save the changed mixer_paths.xml and reboot your device for good measure

Enjoy your actually functional microphone! I hope that CM11s fixes this in an update shortly. It is not fixed as of July 4, 2014

I AM THE ORIGINAL POSTER
Gabriel Hahr AKA Kokorone

If you want my original Oneplus One forum post, search it up under the CM11s section of their forum. I am not able to link it here because I just joined XDA.
Thanks! Worked great.


If I've helped you out, don't forget to click thanks!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Control Your Toast Notifications with SlicedToasts

Toasts are delicious, even in their Android flavor. In Android, toast doesn’t lead … more

Rotation Lets You Take Full Control of Your Device’s Orientation Settings

To be brutally honest, the native options for screen … more

Change the Alarm Icon in the Status Bar with Xposed

It’s hard to find a more hated object than your alarm clock. They wake us up nearly … more

Return to Outer Space Outer Space with Ship Up Game

Since the release of Flappy Birds, we’ve had the “fortune” to see … more