Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,458 Members 47,367 Now Online
XDA Developers Android and Mobile Development Forum

Haptic no longer working

Tip us?
 
toohsieh
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 14
Join Date: Nov 2012
Location: San Jose, CA
Default Haptic no longer working

Even though I enabled vibrate on touch in my sound settings, I never get haptic feedback for anything. I've enabled haptic in my SwiftKey settings as well, but no dice. Weird thing is, I could have sworn I had haptic when I first got this phone, but now it's gone and I can't fathom why. Has anyone had this issue before?

Sent from my One using XDA Free mobile app
 
stu5797
Old
#2  
stu5797's Avatar
Senior Member
Thanks Meter 194
Posts: 1,197
Join Date: Aug 2011
Location: Cleveland, Ohio
Quote:
Originally Posted by toohsieh View Post
Even though I enabled vibrate on touch in my sound settings, I never get haptic feedback for anything. I've enabled haptic in my SwiftKey settings as well, but no dice. Weird thing is, I could have sworn I had haptic when I first got this phone, but now it's gone and I can't fathom why. Has anyone had this issue before?

Sent from my One using XDA Free mobile app
Couple if things. I had to go into the SwiftKey settings and turn up keyless vibration from to to 25. After that you may have battery saver enabled which would turn off your vibration
OnePlus One = Good
 
swrajjoshi
Old
#3  
Member
Thanks Meter 4
Posts: 84
Join Date: Oct 2010
Location: Sydney
Quote:
Originally Posted by toohsieh View Post
Even though I enabled vibrate on touch in my sound settings, I never get haptic feedback for anything. I've enabled haptic in my SwiftKey settings as well, but no dice. Weird thing is, I could have sworn I had haptic when I first got this phone, but now it's gone and I can't fathom why. Has anyone had this issue before?

Sent from my One using XDA Free mobile app
I posted this under another topic dealing with vibrator issues.

I think this is bug from profiles or quiet hours. The link to cyanogen mod bug-
https://jira.cyanogenmod.org/browse/BACON-467

I have owned OPO for few days and probably on 2nd day I lost the vibration. This was driving me crazy for last few days, I even raised a ticket with OPO hardware thinking the motor is shot but then I can see that the phone vibrates on bootup. I recently came across someone saying that the file sys/devices/virtual/timed_output/vibrator/enable value staying as 0 is causing the motor to not work. Come to think of it, I started using profiles and quiet hours from next day.

I don't know if there's a workaround editing the enable file value to 1? I think my notification LED light is also not working cause of the issues with quiet hours.
Using - OnePlus One (stock Cyanogen 11s)

Phones owned - Nokia 6200 | HTC 8525 | Apple iPhone 3G | Samsung Galaxy S | Blackberry Torch| Apple iPhone 4s | Sony Xperia Z | OnePlus One
 
AZImmortal
Old
#4  
Senior Member
Thanks Meter 69
Posts: 466
Join Date: Dec 2010
I just wanted to say that my haptic feedback suddenly went away as well. Does anyone have any new leads regarding this?
 
swrajjoshi
Old
#5  
Member
Thanks Meter 4
Posts: 84
Join Date: Oct 2010
Location: Sydney
Quote:
Originally Posted by AZImmortal View Post
I just wanted to say that my haptic feedback suddenly went away as well. Does anyone have any new leads regarding this?
I think I saw a bug report on that in jira, I'll try post number soon.

Sent from my A0001 using XDA Free mobile app
Using - OnePlus One (stock Cyanogen 11s)

Phones owned - Nokia 6200 | HTC 8525 | Apple iPhone 3G | Samsung Galaxy S | Blackberry Torch| Apple iPhone 4s | Sony Xperia Z | OnePlus One
 
pifsworld
Old
#6  
pifsworld's Avatar
Senior Member
Thanks Meter 10
Posts: 184
Join Date: May 2010
Make sure the intensity option is at full. I've managed to disable mine using this

Sent from my A0001 using XDA Free mobile app
 
żGotJazz?
Old
#7  
żGotJazz?'s Avatar
Senior Member
Thanks Meter 38
Posts: 320
Join Date: Oct 2006
I have found this to be related to the Quiet Hours functionality. Even if I am not in an active quiet profile, the haptic feedback does not function. By fully disabling the Quiet Hours functionality, the haptic feedback was restored.
żGotJazz?

If I've helped you out, send a little "thanks" my way ...

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes