Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] GPS not fixing/locking while on mobile data transfer

OP mikeyo1984

2nd July 2014, 10:21 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jul 2014
Hi ive posted this in cyanogenmod forums, but maybe someone here experienced similiar issue:

Recently i got myself OnePlus One /China version/. At the moment i have it flashed with CM11 Nightly 01072014.

Everything works fine but the GPS. I am having some odd iggues with it. While it locks correct when im at home (WiFi connection enabled), when i leave home and start using navigation software, be it google maps or anything else, after i go out of reach from Wifi and mobile swaps to Mobile data transfer (HSPDA+) gps loses fix and cant get it locked back up anymore.

When i disable mobile data, it locks back up... so it seems like the issue is connected to mobile data transfer. Its pretty annoying since im using maps that require being 'online' which pretty much forces me to use offline maps.

Anyone ever faced similiar issue? Dont see how it could be connected to my carrier (T-Mobile Poland) since few days back when i was still on my older ACE2, all gps functions on that phone worked fine whilst being on mobile data etc. Only difference might be it wsnt HSPDA+ cappable....

Suggestions? This really is doing my head in, ive been googling around like crazy, trying all kinds of GPS 'fixes' but issue remains and most likely involves that mobile data transfers somehow.
2nd August 2014, 02:33 AM   |  #2  
SystemErrorOne's Avatar
Recognized Contributor
Flag Jacksonville
Thanks Meter: 326
 
481 posts
Join Date:Joined: Jun 2011
More
I too am having this problem, what Im going to do is just flash a new radio (baseband) from the stock CM11S rom or maybe another rom and hope for the best. Remember ALWAYS make a back up before you do any mods to your oneplus.
6th September 2014, 06:38 PM   |  #3  
Junior Member
Flag Heredia
Thanks Meter: 2
 
19 posts
Join Date:Joined: Jun 2013
More
Hi. This issue is driving me crazy. I've been looking for more information but I've only found this thread, a CyanogenMod jira bug (look for issue BACON-115, I can't post links yet), and an issue at Android Open Source Project issue tracker (look for Issue 72311: GPS losing satellites - Nexus 5 - 4.4.3 and 4.4.4)

I first found the jira bug, so I tried the gps.confg settings referenced there, after that the issue was slightly (very little actually) less annoying but the GPS still got lost very frequently, I believe those settings just improved locking/fixing times a bit.

Then I started tinkering with my settings while driving (in stop lights of course, not while actually moving ) and I noticed that as soon as I turned mobile data OFF, the GPS locked immediately and never got lost from work to home (a 30 min drive).

So I started querying Google for things like "GPS lost while mobile data on", after about an hour I got the bug in code.google.com, which suggests it's only happening while 3G data is on, not while 2G. And it is, I can get a constant GPS fix while on 2G. The bug thread hinted about flashing different versions of the radios to find a version that works.

I remembered that with OPO firmware 25R this issue was far less annoying so I went ahead and flashed only the radios from 25R. It was not completely fixed, but my yesterday commute got significantly less GPS signal loss, and when it got loss it took less time to fix again, which I attribute to the gps.conf from the jira bug.

TL;DR
I've experienced this issue with 30O and 33R firmwares and with CM Nightlies (which I'm using right now), but slightly less annoying with 25R. Flashing 25R radios and using the modified gps.conf alleviated the issues a lot but I still get frequent GPS signal lost. Turning off 3G will definitely make GPS fix/lock constantly.

I wonder if there are older radios that could get rid of the issue completely (and what drawbacks using older radios could bring), meanwhile I'm using Tasker to fall back to 2G as soon as I'm connected to my car's bluetooth AND Waze is opened, so that I can get a constant GPS fix/lock while driving.
17th October 2014, 03:25 PM   |  #4  
Member
Thanks Meter: 0
 
39 posts
Join Date:Joined: Sep 2011
More
I think this is an Android 4.4.3/4.4.4 issue, please vote here so that google takes notice of this.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes