FORUMS

3D Printable Mobile Microscope? Nexus 7 Discontinued – XDA TV

The Nexus 7 2013 has been discontinued on the Google Store! That and … more

Which Lockscreen Security Type Do You Use?

From pattern locks to the controversial face unlock, there are a number of different ways you … more

Xposed 3.0 Alpha 3 Released

A new alpha for the Xposed framework is out and brings several bug fixes. You’ll only need to flash … more

XDA Recap: This Week In Android (Apr 18 – 25)

Here in the digital XDA newsroom, we spend our days pouring over an average of … more
Post Reply Subscribe to Thread Email Thread

HELP ME!!! build.prop file deletes itself upon reboot!!!

21st August 2014, 10:22 PM |#1  
OP Member
Thanks Meter: 1
 
More
HEY!!

I wanted to change my LCD density on the build.prop file with build.prop Editor. It worked fine.

When I tried to copy the backup back from sdcard and replace the edited build.prop with the stock one, after reboot all I can see is the OnePlus logo with the "POWERED BY ANDROID" text.

I can access TWRP, but when I check the /system directory, there is no build.prop file. So I move it again from sdcard to the /system directory. It stays there until I reboot the phone.

I did EVERYTHING! chmod, mounting, moving using adb shell, and the file just deletes itself when I reboot the phone!!

I don't want to make a factory reset since I don't have a latest backup.

Please don't ask me why did I change the LCD density. I just wanted to check something.

PLEASE HELP!!
 
 
21st August 2014, 10:40 PM |#2  
Setting.Out's Avatar
Senior Member
Flag Asnieres-Sur-Seine
Thanks Meter: 1,799
 
More
Quote:
Originally Posted by Machlev

HEY!!

I wanted to change my LCD density on the build.prop file with build.prop Editor. It worked fine.

When I tried to copy the backup back from sdcard and replace the edited build.prop with the stock one, after reboot all I can see is the OnePlus logo with the "POWERED BY ANDROID" text.

I can access TWRP, but when I check the /system directory, there is no build.prop file. So I move it again from sdcard to the /system directory. It stays there until I reboot the phone.

I did EVERYTHING! chmod, mounting, moving using adb shell, and the file just deletes itself when I reboot the phone!!

I don't want to make a factory reset since I don't have a latest backup.

Please don't ask me why did I change the LCD density. I just wanted to check something.

PLEASE HELP!!

Reflash your ROM... Don't wipe the data partition and all will be as it was before.

Sent from my OnePlus ONE
21st August 2014, 10:48 PM |#3  
OP Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Setting.Out

Reflash your ROM... Don't wipe the data partition and all will be as it was before.

Sent from my OnePlus ONE

no MD5 file found while installing via TWRP. Should I wipe /system?
Last edited by Machlev; 21st August 2014 at 10:53 PM.
21st August 2014, 10:57 PM |#4  
OP Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Setting.Out

Reflash your ROM... Don't wipe the data partition and all will be as it was before.

Sent from my OnePlus ONE

I wiped system and pushed an md5 file. Still fails with no reason.

I use this ROM -

https://cyngn.com/products/oneplusone/

(On the bottom)
Last edited by Machlev; 21st August 2014 at 10:59 PM.
22nd August 2014, 10:48 PM |#5  
Setting.Out's Avatar
Senior Member
Flag Asnieres-Sur-Seine
Thanks Meter: 1,799
 
More
What error are you getting?.. You could try another download (that one may be corrupt) or CM11 ROM, you should still be able to keep your app data as long as you don't wipe that partition.. You only need to wipe system/dalvik/cache..

Sent from my OnePlus ONE
23rd August 2014, 09:54 AM |#6  
Senior Member
Flag Cali
Thanks Meter: 111
 
Donate to Me
More
Are you mounting /system with TWRP before doing that?

Also, dont move the file, try cp which works better with crosslink devices

And try chmod 755 /system/build.prop with adb while in recovery and check the build.prop isnt edited in Windows so EOL is Windows-like, then use Notepad++ to change to UNIX-type
23rd August 2014, 10:04 AM |#7  
bachera's Avatar
Senior Member
Thanks Meter: 587
 
More
easy, you copy pasted so permissions are not the same as the original

reflash system or rom

Sent from my A0001 using XDA Free mobile app
24th August 2014, 01:06 AM |#8  
timmaaa's Avatar
XDA: ASSIST
Recognized Contributor
Flag Melbourne
Thanks Meter: 9,366
 
Donate to Me
More
Yep. Permissions should be rw-r-r (or 644). If you don't know what you're doing don't mess around with system files.

Transmitted via Bacon
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in ONE Q&A, Help & Troubleshooting by ThreadRank