Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,814,105 Members 45,230 Now Online
XDA Developers Android and Mobile Development Forum

Problem with ART

Tip us?
 
rbnhan89
Old
#1  
rbnhan89's Avatar
Member - OP
Thanks Meter 2
Posts: 34
Join Date: Jul 2011
Location: Philadelphia
Default Problem with ART

So I finally enabled ART as my runtime and came across a problem. I am complete stock with no adjustment until now. Its smooth as eggs but now my internet doesn't even go LTE nor 4g. It'd always stuck at h+ rather than mainly on LTE. As I am writing this, I always have LTE in this spot before i enabled ART but it takes like 15 mins to to convert from H+ to LTE. Is this a problem that usually occur and if so, I cannot find the solution for it.
history: HTC G1 -> HTC MyTouch 4g -> HTC Sensation 4g -> Samsung Galaxy Note II -> Oneplus One

Current Phone: Oneplus One 64 GB Sandstone Black
Carrier: US T-Mobile
ROM: Stock CM 11s version XPNH30O
Android Version: 4.4.4
Kernel: Stock
Radio: Stock
Battery: Stock

 
maddog975
Old
#2  
Junior Member
Thanks Meter 1
Posts: 12
Join Date: Apr 2011
Location: Chicago
Art is still kind experimental. I know from experience certain apps will not run under ART and some roms have limited or incomplete implementations of art. I have tried using art periodically ever since Google offered it on the nexus devices but find I always have a issue with something so end up reverting to davilk.

Sent from my A0001 using XDA Free mobile app
The Following User Says Thank You to maddog975 For This Useful Post: [ Click to Expand ]
 
masterchop
Old
#3  
Member
Thanks Meter 10
Posts: 77
Join Date: May 2011
Thumbs up This is a helpful message :)

Yea, go back to Dalvik and confirm if its a Runtime issue, you could also try using another ROM.
The Following User Says Thank You to masterchop For This Useful Post: [ Click to Expand ]
 
S M G
Old
(Last edited by S M G; 9th September 2014 at 09:18 PM.)
#4  
S M G's Avatar
Member
Thanks Meter 29
Posts: 71
Join Date: Dec 2012
Location: 30.0000 S, 25.0000 E
Love ART but it is just to new/unsupported/buggy at this point in time to use as a daily driver IMHO. Obviously people have different experiences with ART but mine wasn't so great. I would just stick with Dalvik for the time being,ART its still a relatively new run-time and problems like these are bound to happen.
YOUR ATTITUDE DETERMINES YOUR LATITUDE
The Following User Says Thank You to S M G For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes