Post Reply

[Q] Speakerphone volume very low during calls?

OP sonofthor

8th August 2014, 03:24 PM   |  #31  
Red5's Avatar
Retired Forum Moderator
Thanks Meter: 2,079
 
2,087 posts
Join Date:Joined: Oct 2007
Yup, this fixed my issue. Glad to hear that it will be included in the next OTA update, but for now if you have low in-call volume, this mod will fix that. Thanks again!

---------- Post added at 07:24 AM ---------- Previous post was at 07:22 AM ----------

Quote:
Originally Posted by tiny4579

Could always push the acdb files from a recent nightly. I can upload them later if you want to do that. IMO it works better than the mixer_paths.xml edits.

This works better than the mixer_paths edit? Now I really cant wait for the next update.
8th August 2014, 03:35 PM   |  #32  
Recognized Contributor
Flag New York, NY
Thanks Meter: 5,486
 
13,324 posts
Join Date:Joined: Aug 2009
Donate to Me
More
Quote:
Originally Posted by Red5

Yup, this fixed my issue. Glad to hear that it will be included in the next OTA update, but for now if you have low in-call volume, this mod will fix that. Thanks again!

---------- Post added at 07:24 AM ---------- Previous post was at 07:22 AM ----------

This works better than the mixer_paths edit? Now I really cant wait for the next update.

I suppose I can just open up the mixer paths from the cm nightly and copy the values

Sent from my One using Tapatalk
Edit: Seems like the values on CM11 nightlies are the same as the ones that they are now. They must have done the changes somewhere else. Too lazy to look for the commit.
Last edited by zephiK; 8th August 2014 at 03:43 PM.
8th August 2014, 06:26 PM   |  #33  
Recognized Developer
Thanks Meter: 4,228
 
7,908 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by zephiK

I suppose I can just open up the mixer paths from the cm nightly and copy the values

Sent from my One using Tapatalk
Edit: Seems like the values on CM11 nightlies are the same as the ones that they are now. They must have done the changes somewhere else. Too lazy to look for the commit.

Its the acdb files in /system/etc/acdbdata/MTP. Copt them from a recent nightly. Oh yeah. I was going to upload them.


Edit: try this https://www.dropbox.com/s/9yla2xej4b7hqd3/acdbdata.zip
Last edited by tiny4579; 8th August 2014 at 06:34 PM.
The Following User Says Thank You to tiny4579 For This Useful Post: [ View ]
8th August 2014, 07:59 PM   |  #34  
Member
Thanks Meter: 6
 
87 posts
Join Date:Joined: Dec 2013
More
Is this the volume of the loudspeaker or normal speaker whilst on the phone?

When I am on the phone, I haven't been able to hear anyone.. Only a very quiet muffle. How can I fix this? It has worked previously.
14th August 2014, 01:34 PM   |  #35  
Recognized Developer
Thanks Meter: 4,228
 
7,908 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by 7ewis

Is this the volume of the loudspeaker or normal speaker whilst on the phone?

When I am on the phone, I haven't been able to hear anyone.. Only a very quiet muffle. How can I fix this? It has worked previously.

Restore all mixer files to stock and push the files I uploaded or wait for the OTA. You probably updated the wrong path.
20th August 2014, 01:36 PM   |  #36  
Senior Member
Basel
Thanks Meter: 15
 
199 posts
Join Date:Joined: Mar 2011
Exclamation
Quote:
Originally Posted by ToRvaLDs

You have to mount the /system as RW ( you can use ES FIle Explorer https://play.google.com/store/apps/d...gs.android.pop )

Edit the file in /system/etc/mixer_paths.xml

Around the line 571 you will find

Code:
<!-- Analog output devices -->
<path name="ear">
you are in the right section, so in the same section around the line 576 you will find:

Code:
<ctl name="RX1 Digital Volume" value="84">
Change the value (84) to an higher number I tried 100 and it's very loud, It think 92/95 could be enough.

MAKE A COPY OF THAT FILE BEFORE EDIT IT.

Thanks to C13v3r0n3 for the right way

Quote:
Originally Posted by MarvinFS

My 5 cents!
For loud-speaker vol and for ring vol edit those in the same file:

<!-- Output paths -->
<path name="speaker">
<ctl name="RX3 Digital Volume" value="90" />
<ctl name="RX4 Digital Volume" value="90" />

<path name="voice-speaker">
<ctl name="RX3 Digital Volume" value="95" />
<ctl name="RX4 Digital Volume" value="95" />

Hi guys, to summarise: which is the best final solution to solve the ugly problem of the volume during a call?

I would like to solve this problem once for all
I have the last Madhi ROM on my 1+1.
20th August 2014, 02:38 PM   |  #37  
Recognized Developer
Thanks Meter: 4,228
 
7,908 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by albyXR

Hi guys, to summarise: which is the best final solution to solve the ugly problem of the volume during a call?

I would like to solve this problem once for all
I have the last Madhi ROM on my 1+1.

Get your ROM to update the acbdata files.
20th August 2014, 03:53 PM   |  #38  
Senior Member
Basel
Thanks Meter: 15
 
199 posts
Join Date:Joined: Mar 2011
Exclamation
Quote:
Originally Posted by tiny4579

Get your ROM to update the acbdata files.

...? sorry but I don't understand, I am not new in the forum but what is acbdata files???
I was searching only the right .zip to flash in recovery for get a loud volume during a phone call..
20th August 2014, 04:25 PM   |  #39  
Recognized Contributor
Flag New York, NY
Thanks Meter: 5,486
 
13,324 posts
Join Date:Joined: Aug 2009
Donate to Me
More
Quote:
Originally Posted by tiny4579

Get your ROM to update the acbdata files.

I believe Mahdi already updated the acbdata files. I'm on the latest Mahdi and don't have any problems with phone calls and have noticed that the speaker is louder with the stock values.

OP Did you update to 08/18 build?
20th August 2014, 04:48 PM   |  #40  
Senior Member
Basel
Thanks Meter: 15
 
199 posts
Join Date:Joined: Mar 2011
Exclamation
Quote:
Originally Posted by zephiK

I believe Mahdi already updated the acbdata files. I'm on the latest Mahdi and don't have any problems with phone calls and have noticed that the speaker is louder with the stock values.

OP Did you update to 08/18 build?

yes, today, but the phone call is still low.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in ONE Q&A, Help & Troubleshooting by ThreadRank