Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,803,209 Members 43,989 Now Online
XDA Developers Android and Mobile Development Forum

Superuser/TWRP installed but no root?

Tip us?
 
Talnoy
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 22
Join Date: Jun 2011
Default Superuser/TWRP installed but no root?

Hey guys,

Just got my OnePlus One today and did a oem unlock and root/custom recovery via command line, and I have the SuperSU app installed, it works when starting, installs successfully (or so it says) but whenever I try to use an app requiring SU access it just crashes and doesn't prompt me for access...

What happen and how do I fix it?
 
Talnoy
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 22
Join Date: Jun 2011
Update with screenshots


So I tried the windows AND Mac toolkits. The windows one just doesn't detect java so it doesn't work at all, and the Mac one "worked" but I'm still getting the exact same issue. Super SU is installed, and apparently working, but doesn't give root.

Shot 1 is my SuperSU app - clearly says SU is Enabled.

Shot 2 is Root Checker....which is clearly showing that I don't have root.



Wat.

Any help would be HUGELY appreciated as I'm very excited to use this phone...but oh god how spoiled I've been with AdBlocking. No root is poop.
 
zephiK
Old
#3  
Recognized Contributor
Thanks Meter 4,662
Posts: 12,463
Join Date: Aug 2009
Location: New York, NY

 
DONATE TO ME
Your post is so confusing..... just download http://download.chainfire.eu/451/Sup...erSU-v2.01.zip
and flash it in TWRP then reboot.
Follow me on Twitter! | Scrolling Mods for Various OPO Roms

OnePlus One: Mahdi | Franco Kernel
Older devices: Nexus 5, Nexus 4, Galaxy Nexus, TF101, Nexus S, Samsung Vibrant, G1

 
Talnoy
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 22
Join Date: Jun 2011
Quote:
Originally Posted by zephiK View Post
just download http://download.chainfire.eu/451/Sup...erSU-v2.01.zip
and flash it in TWRP then reboot.
I have though :/


I still don't have root - root checker keeps coming back as negative
 
AJ RIMMER!
Old
#5  
Member
Thanks Meter 7
Posts: 36
Join Date: Jul 2014
Location: Sydney
Inside SuperSU app, in the settings ...

Scroll down to the CyanogenMod heading ...

Make sure that the RESPECT CM ROOT SETTINGS is unchecked.

I had to do this to get Titanium Backup to respond.

Good luck.
The Following User Says Thank You to AJ RIMMER! For This Useful Post: [ Click to Expand ]
 
playya
Old
#6  
playya's Avatar
Senior Member
Thanks Meter 1,940
Posts: 5,748
Join Date: Jan 2007
Location: Florida

 
DONATE TO ME
Quote:
Originally Posted by Talnoy View Post
Hey guys,

Just got my OnePlus One today and did a oem unlock and root/custom recovery via command line, and I have the SuperSU app installed, it works when starting, installs successfully (or so it says) but whenever I try to use an app requiring SU access it just crashes and doesn't prompt me for access...

What happen and how do I fix it?
What instruction did you use?
DeBloat your AOKP/CM10 fast and pain free click here
---------------------------------------------------
"Hey if you can type it you can search it" - Google is your friend - Let me Google that for you
--------------------------------------------------
Proud owner of a 1+1 What you know bout dat life!
 
Talnoy
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 22
Join Date: Jun 2011
Quote:
Originally Posted by AJ RIMMER! View Post
Inside SuperSU app, in the settings ...
Make sure that the RESPECT CM ROOT SETTINGS is unchecked.
Good luck.
THAT did the trick. I'm guessing it's because the app thinks we're running CM that it comes with SU.

Thanks for the hand.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes