Post Reply

Superuser/TWRP installed but no root?

OP Talnoy

25th July 2014, 02:24 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2011
Hey guys,

Just got my OnePlus One today and did a oem unlock and root/custom recovery via command line, and I have the SuperSU app installed, it works when starting, installs successfully (or so it says) but whenever I try to use an app requiring SU access it just crashes and doesn't prompt me for access...

What happen and how do I fix it?
25th July 2014, 03:16 AM   |  #2  
OP Junior Member
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2011
Update with screenshots


So I tried the windows AND Mac toolkits. The windows one just doesn't detect java so it doesn't work at all, and the Mac one "worked" but I'm still getting the exact same issue. Super SU is installed, and apparently working, but doesn't give root.

Shot 1 is my SuperSU app - clearly says SU is Enabled.

Shot 2 is Root Checker....which is clearly showing that I don't have root.



Wat.

Any help would be HUGELY appreciated as I'm very excited to use this phone...but oh god how spoiled I've been with AdBlocking. No root is poop.
25th July 2014, 03:23 AM   |  #3  
Recognized Contributor
Flag New York, NY
Thanks Meter: 5,392
 
13,289 posts
Join Date:Joined: Aug 2009
Donate to Me
More
Your post is so confusing..... just download http://download.chainfire.eu/451/Sup...erSU-v2.01.zip
and flash it in TWRP then reboot.
25th July 2014, 03:54 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2011
Quote:
Originally Posted by zephiK

just download http://download.chainfire.eu/451/Sup...erSU-v2.01.zip
and flash it in TWRP then reboot.

I have though :/


I still don't have root - root checker keeps coming back as negative
25th July 2014, 04:23 AM   |  #5  
Member
Flag Sydney
Thanks Meter: 7
 
47 posts
Join Date:Joined: Jul 2014
Inside SuperSU app, in the settings ...

Scroll down to the CyanogenMod heading ...

Make sure that the RESPECT CM ROOT SETTINGS is unchecked.

I had to do this to get Titanium Backup to respond.

Good luck.
The Following User Says Thank You to AJ RIMMER! For This Useful Post: [ View ]
25th July 2014, 05:52 AM   |  #6  
playya's Avatar
Senior Member
Florida
Thanks Meter: 2,018
 
5,948 posts
Join Date:Joined: Jan 2007
Donate to Me
Quote:
Originally Posted by Talnoy

Hey guys,

Just got my OnePlus One today and did a oem unlock and root/custom recovery via command line, and I have the SuperSU app installed, it works when starting, installs successfully (or so it says) but whenever I try to use an app requiring SU access it just crashes and doesn't prompt me for access...

What happen and how do I fix it?

What instruction did you use?
25th July 2014, 01:36 PM   |  #7  
OP Junior Member
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2011
Quote:
Originally Posted by AJ RIMMER!

Inside SuperSU app, in the settings ...
Make sure that the RESPECT CM ROOT SETTINGS is unchecked.
Good luck.

THAT did the trick. I'm guessing it's because the app thinks we're running CM that it comes with SU.

Thanks for the hand.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in ONE Q&A, Help & Troubleshooting by ThreadRank