How to Root Android Wear 5.0.1 Lollipop Devices – XDA TV

The Lollipop update for Android Wear devices has hit the market and people are … more

Android 5.0.2 and New Factory Images For Nexus 7 (Wi-Fi) Available

Android 5.0 is has been publicly available since early November, and the … more

Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] [PROBLEM] Searching for a kernel with 64 GB SD support

OP viil

5th July 2014, 04:57 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2010
Hi. Please advise on my problem as follows.

I have an LG-P880 running Android 4.4.2 with LiquidSmooth LS-KK-v3.0-2014-02-12, Kernel: 3.1.10-CM+(2014-102-12).
Recently, I bought Sandisk Ultra 64 GB microSDXC I. I format it in Windows into FAT 32, insert in the phone slot, the phone says "SD card is blank or has unsupported filesystem". Format? - I press OK. It shows "Erasing" for about 3 minutes and then reboots itself. On reboot, it says "sd card is damaged try reformatting it". I take it out, connect to PC - card is unreadable, even checkdisk freezes. I connect it to Mac - Disk Utility (probably the best way to fix unreadable cards) - Erase, Verify, Repair - format under exFAT. Test read/write - works fine; try in Windows - works fine. I put it back into the phone, I get on of the above messages, then it reboots and goes on like this forever... And I have to go through the same steps for it to make it readable again.
Next step: The card is freshly formatted (tried both exFAT and FAT 32), Reboot in Recovery (CWM latest version) -> mounts & storage -> format -> "cannot mount SD card... Skipping format".
So, I've pretty much tried all options. My previous SD was 16 GB, never had problems, so exclude slot/hardware issues.

I searched for similar problems and it's mostly only 2 solutions:
  1. Try a different card, cause not all of them can be read by a phone, although work on PC.
  2. Kernel does not support SD cards over 16/32 GB.

I don't have a chance to try other cards, as this is the only one I have and I ordered it by post. It works on computers - so no warranty condition for exchange. Therefore, my question is
  • Can somebody confirm a kernel version which supports this type of card, tested, with a direct link please?
  • As I've never updated kernel separately before, will all my settings remain or will I need to do a factory reset afterwards?

Thank you in advance!
5th July 2014, 11:52 PM   |  #2  
Junior Member
Thanks Meter: 2
 
4 posts
Join Date:Joined: Jan 2011
I had nearly the same problems with a Sandisk 64 GB card. I send it back. Now I have a Samsung one.

Gesendet von meinem LG-P880 mit Tapatalk
6th July 2014, 06:07 AM   |  #3  
akshay.mehta9's Avatar
Senior Member
Flag Ahmedabad
Thanks Meter: 70
 
259 posts
Join Date:Joined: Apr 2013
I have transcend 64gb class4 microsdhc card and it's works
I think your ultra microsdxc card is not supportable with p880

Sent from my LG-P880 using Tapatalk
19th July 2014, 02:10 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2010
So, I returned that one and now I have Kingston 64 GB - same story...
Now, can anybody advise on Kernel?
27th July 2014, 10:55 AM   |  #5  
Member
Flag Cairo
Thanks Meter: 36
 
91 posts
Join Date:Joined: Jul 2014
More
have you tried iodak v10 kernel?
28th July 2014, 08:40 PM   |  #6  
Senior Member
Thanks Meter: 171
 
372 posts
Join Date:Joined: Jan 2013
More
You should try to format it via TWRP.

I've heard people had problems with CWM when they use sd cards with big storage.Maybe formatting the card from there could help.

Also try what tamer7 said.Maybe the stock LS kernel does not support 32 GB + sd cards, while hardware does.
29th July 2014, 03:09 PM   |  #7  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2010
Will certainly give it a try next week and then report here, if all goes well - a thank for everyone!
So, will everything reset if I just flash kernel in CWM or everything will stay?
29th July 2014, 04:35 PM   |  #8  
Senior Member
Thanks Meter: 171
 
372 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by viil

Will certainly give it a try next week and then report here, if all goes well - a thank for everyone!
So, will everything reset if I just flash kernel in CWM or everything will stay?

No changes will be made.Only dalvik cache will be wiped.

However, it is recommended that you delete the data of applications which directly change kernel settings, such as CPU governor, cpu max frequency, sysctl or io governor etc.

I'd recommend you to flash a rom and then flash the kernel right after it, before rebooting from recovery screen.Feel free to just dirtyflash the kernel though.
The Following User Says Thank You to ottomanhero For This Useful Post: [ View ]
1st September 2014, 05:40 AM   |  #9  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2010
Solved
Well, the solution wasn't so dramatic. I just upgraded my ROM to the latest version and everything started working, even in CWM I can see the card now.
Too bad that I couldn't post this question directly into development thread, due to insufficient rights. I wouldn't have to bother everyone in general forum.
Thanks to everyone for the advice.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes