FORUMS

[Guide] Install Cyanogenmod 12.1 on LG E977 and E975 (not tested)

1 posts
Thanks Meter: 1
 
By ntocampos, Junior Member on 24th May 2015, 05:35 AM
Post Reply Subscribe to Thread Email Thread
Hi guys.

This post was made with the intent of help those who are having a hard time trying to update from CM 12 or older versions to CM 12.1.
Inicially I was having the "blkdiscard" error when trying to flash the ROM.
After a lot of searching, I found that the partitions where in a "wrong" format.
So, I tried and tried to change this manually with TWRP, with no success.
Looking in a post about a similar error, I found the answer of ircalf.

I'm posting it here with some modifications.
Italic text means my comments/adds to the guide. Normal text means ircalf comments.

1) The reason why I couldn't flash cm12.1 before was that my /system partition had a different size than what was expected by the cm package.
Apparently, that happens with the e977 original firmware.
So I flashed the european v10h kdz, in order to remake all the partitions in the correct size.
The .kdz file mentioned can be found here (used the V10H Europe Open). I used the LG Tool found here.
My setup at LG Flash Tool 2014 as follows: type 3GQCT, phone mode DIAG, open european kdz mentioned above. Then Normal flash > Start > English language > OK.
At the middle of the process, a connection error was given by the LG Updater, but don't worry and don't click OK at the new window. Just drag it and see that the process still going on.


2) I rooted and unlocked the booatloader again, same as always.

3) I flashed the latest nexus 4 bootloader and philz recovery (personal preferences, don't know if it makes any difference)
Nexus 4 bootloader can be found here.

4) I flashed cm12.1 and gapps, and it didn't boot (went to a black screen right after the bootloader logo)
Here it booted, but the initial configuration app always crashes.

5) I formated the /data and /system partitions and installed cm11, and it booted alright.
I didn't installed CM 11 but I did formated /data and /system. So...

6) I flashed cm12.1 again and it booted.
Didn't worked for me. Same initial config app crash.
Then I installed the latest Kevinjoa build and it worked.


7) I think that cm11 had nothing to do with it. The reason why cm12.1 didn't boot at first was probably because of the /data partition that needed to be formated.
... I also think that.

This process was made on a LG E977 device. I didn't tested on the E975, but probably it works there too.
If you did tested and it worked, please tell me so I can remove the "(not tested)" from the title.

Many thanks to everyone from the mentioned posts, you helped a lot.
Sorry for my bad english. Hope it helps.
Last edited by ntocampos; 24th May 2015 at 05:41 AM. Reason: Wrong link and style.
The Following User Says Thank You to ntocampos For This Useful Post: [ View ]
 
 
27th May 2015, 02:36 AM |#2  
Junior Member
Thanks Meter: 0
 
More
Lg g2
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes