FORUMS

[Q] Phone won't charge

96 posts
Thanks Meter: 19
 
By jordy1990, Member on 4th August 2014, 10:38 PM
Post Reply Subscribe to Thread Email Thread
After my Optimus G shutoff due to a low battey, it won't charge and boot anymore. I've tried plugging it into the computer and also tried 2 different chargers but still the phone won't charge. Is there a way to try to make it boot again?

My phone is rooted, but the bootloader is locked and I installed the E975 V20A kitkat rom trough a KDZ file because kitkat is not yet supported in my country. Could my phone still be returned under warranty?
 
 
4th August 2014, 10:43 PM |#2  
ITzRicardo94's Avatar
Senior Member
Flag Oranjestad
Thanks Meter: 19
 
More
Let it charge at the wall charger for at least 30 minutes, then try to press the power button. I have gone through that too. Does your phone show red led? Or it doesn't do anything at all? Let it charge at the wall charger for at least 15~30 minutes. I was scared too when it happened to me, I thought my phone had died. I had 7% and suddenly it turned off and didn't want to turn on showing red led and it didn't show as if it were charging, but after 10 minutes plugged in to the wall charger it started showing that it was charging.
The Following User Says Thank You to ITzRicardo94 For This Useful Post: [ View ]
5th August 2014, 11:59 AM |#3  
OP Member
Thanks Meter: 19
 
More
I had already let it plug in for 20 minutes, but there was no red notification LED. After about an hour on the charger the LED started blinking and the phone went into a bootloop. Then I tried some button combinations and the phone turned off and charged. Everything is OK now, but it got me worried indeed!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes