Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,949 Members 43,430 Now Online
XDA Developers Android and Mobile Development Forum

[Q] No service on phone

Tip us?
 
hanrkd
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 17
Join Date: Mar 2013
Question [Q] No service on phone

So I posted this on the general android help section but didn't get much help so I'll post here too:

Hi everyone, I have an LG Optimus G (F180K) and I've been using it fine for the last couple years and most recently under the V30D firmware which is KitKat 4.4.2. I've flashed CM11 and MIUI on it previously but restored it to the stock rom several months ago and have stuck with it since. About a week ago I flashed MIUI again as it seemed there were new builds avaliable. The installation went fine but when the phone booted up I realized I didn't have any service and my service provider was not being recognized as it just said "No service". It did show there was a SIM card inside though. So using CWM backup I restored back to my original stock rom and realized there was still no service so I did a clean factory reset. That didn't fix the problem so I tried updating the phone with the kdz files straight from LG's servers which still didn't fix the problem. I checked my IMEI which was not broken and the phone number of my SIM card is recognized but it just always "No service". I tried reverting back to stock rom and factory reset multiple times the past week but it still won't work. Any help? Thanks

So basically I have a rooted F180K that won't get service despite a clean IMEI and reverting back to stock rom.
 
syverman
Old
#2  
Senior Member
Thanks Meter 17
Posts: 103
Join Date: Jan 2011
Location: santiago
i have the same problem but in a 977, i did it all but keeps the same searching for network
 
jollaman999
Old
#3  
Member
Thanks Meter 45
Posts: 64
Join Date: Aug 2014
Location: South Korea
Try this with terminal emulation app or adb shell. (You must be rooted!)
If you have problem with sqlite3 command you can download and install with Play Store.


Code:
su
sqlite3 /data/data/com.android.providers.settings/databases/settings.db "UPDATE global SET value = '10' WHERE name = 'preferred_network_mode';"
sqlite3 /data/data/com.android.providers.settings/databases/settings.db "UPDATE global SET value = '0' WHERE name = 'subscription_mode';"
 
syverman
Old
(Last edited by syverman; 6th September 2014 at 05:34 AM.)
#4  
Senior Member
Thanks Meter 17
Posts: 103
Join Date: Jan 2011
Location: santiago
i did it, but i only get gsm network, i can't get 3g, i restore my efs bkup, my modem but keep the same, only gsm


--------------------------------

Flash my carrier kdz, but keep the same, i dont know what's wrong, only gsm, thas all i can get
Tags
clean, doesn't, imei, service, work
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes