Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,888 Members 36,354 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Problem after unlocking bootloader with Freegee

Tip us?
 
ramicba
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Jun 2013
Location: Córdoba
Question [Q] Problem after unlocking bootloader with Freegee

Hi Guys,

I recently unlocked the bootloader of my Optimus G (E987 flashed to E975) using Freegee (Downloaded from the market) and installed TWRP. I did a back up of the EFS partition before this.

Now, I'm having some weird issues when charging the phone while it's off. I noticed that I have a new charging animation and after a few seconds it disappears like the screen it's going to turn off but it never does!! It stays on a black/gray screen but is still on as you can see the brightness. It never turns off! Also, if I unplugged the phone and hit the power button the screen turns on and the charging animation appears, like the phone was still charging :/

I need some help! I downloaded an alternative bootloader. What should I do? Should I flash the alternative bootloader and will this solve the problem?

thanks!!
 
nch26
Old
#2  
Senior Member
Thanks Meter 51
Posts: 294
Join Date: Jun 2012
Quote:
Originally Posted by ramicba View Post
Hi Guys,

I recently unlocked the bootloader of my Optimus G (E987 flashed to E975) using Freegee (Downloaded from the market) and installed TWRP. I did a back up of the EFS partition before this.

Now, I'm having some weird issues when charging the phone while it's off. I noticed that I have a new charging animation and after a few seconds it disappears like the screen it's going to turn off but it never does!! It stays on a black/gray screen but is still on as you can see the brightness. It never turns off! Also, if I unplugged the phone and hit the power button the screen turns on and the charging animation appears, like the phone was still charging :/

I need some help! I downloaded an alternative bootloader. What should I do? Should I flash the alternative bootloader and will this solve the problem?

thanks!!
Do you selected MAKO bootloader, or STOCK bootloader?
I will explain quickly. STOCK bootloader had that problem, you cant charge your phone when its off. We have the MAKO alternative because it work fine, i mean you can charge it off.

PD: im from Argentina too
The Following User Says Thank You to nch26 For This Useful Post: [ Click to Expand ]
 
ramicba
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Jun 2013
Location: Córdoba
Quote:
Originally Posted by nch26 View Post
Do you selected MAKO bootloader, or STOCK bootloader?
I will explain quickly. STOCK bootloader had that problem, you cant charge your phone when its off. We have the MAKO alternative because it work fine, i mean you can charge it off.

PD: im from Argentina too
Hi!! I installed the STOCK bootloader :/ So what's the solution? What can I do now to fix this? Should I "unblock" the bootloader again installing MAKO bootloader? I also downloaded, from the forum, an alternative bootloader (cwm-geeb-4-3-z20i-bootloader_only.zip).

By the way, I didn't see an option to send you a private message!

Muchas gracias!!!
 
GalaxySIIII
Old
#4  
GalaxySIIII's Avatar
Senior Member
Thanks Meter 59
Posts: 938
Join Date: May 2013
it is better not to unlock bootloader .. it causing problems only... on LGs ..
Vivo X3S (mine)
LG F320S (SOLD!)
LG F180S (GF's)
SmartAss®
 
nch26
Old
#5  
Senior Member
Thanks Meter 51
Posts: 294
Join Date: Jun 2012
Quote:
Originally Posted by ramicba View Post
Hi!! I installed the STOCK bootloader :/ So what's the solution? What can I do now to fix this? Should I "unblock" the bootloader again installing MAKO bootloader? I also downloaded, from the forum, an alternative bootloader (cwm-geeb-4-3-z20i-bootloader_only.zip).

By the way, I didn't see an option to send you a private message!

Muchas gracias!!!
You can flash the bootloader that you download, i did this one time. In my case when flash bootloader from recovery no problems. you should dont have problems.
Maybe i dont have the option active?
 
ramicba
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Jun 2013
Location: Córdoba
Quote:
Originally Posted by GalaxySIIII View Post
it is better not to unlock bootloader .. it causing problems only... on LGs ..
I did it cause I needed to solve the baseband issue after flashing my E987 to E975...Freegee has an option to "re-lock" I think it's to install stock recovery and bootloader but I don't have any of those, do you know where I could get them?

Quote:
Originally Posted by nch26 View Post
You can flash the bootloader that you download, i did this one time. In my case when flash bootloader from recovery no problems. you should dont have problems.
Maybe i dont have the option active?
I installed the bootloader that you told me (wm-geeb-4-3-z20i-bootloader_only.zip) but I'm still having the same problem, I don't know what else to do to solve this. I wouldn't want to go back to the stock ROM, I like this one =/

The only problem is that the screen doesn't completely turns off while charging the phone when it's off.
 
nch26
Old
#7  
Senior Member
Thanks Meter 51
Posts: 294
Join Date: Jun 2012
Quote:
Originally Posted by ramicba View Post
I did it cause I needed to solve the baseband issue after flashing my E987 to E975...Freegee has an option to "re-lock" I think it's to install stock recovery and bootloader but I don't have any of those, do you know where I could get them?



I installed the bootloader that you told me (wm-geeb-4-3-z20i-bootloader_only.zip) but I'm still having the same problem, I don't know what else to do to solve this. I wouldn't want to go back to the stock ROM, I like this one =/

The only problem is that the screen doesn't completely turns off while charging the phone when it's off.
Is not a ROM problem, is a bootloader problem. With mako i dont have this issue. But i hear that some people have issues charging with phone off.
with any bootloader. simple charge it with phone on, or restore bootloader backup and go to stock rom...
 
igli83
Old
#8  
Member
Thanks Meter 9
Posts: 36
Join Date: Mar 2011
Location: Italy
Quote:
Originally Posted by nch26 View Post
Is not a ROM problem, is a bootloader problem. With mako i dont have this issue. But i hear that some people have issues charging with phone off.
with any bootloader. simple charge it with phone on, or restore bootloader backup and go to stock rom...
hmmm... i install mahdi rom ... and i don't notice this issue. than it's not just a bootloader prob i think.anyway!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes