Post Reply

[Q] Photosphere and Panorama not working

4th September 2014, 05:58 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2014
Hi guys and gals,

I've never tried to use photospheres or panorama mode on my phone before and decided to give it a whirl yesterday. It didn't work. It was just a gray screen with dots/rectangle telling me to move the circle into the bigger circle. I can move the circle and "gray dot world" around but that's it. My current rom is CM11 official nightlies (I update it every day or two). I've tried reflashing gapps (with the .forcegallery file in place), removing gapps, using the 4.4.4 micro module gapp, the aroma installer for photosphere fix, some other xda thread's JB photosphere zip, reflashing to stock, reflashing to other ROMs, downloading google camera from the play store, and doing all of the previous gapp stuff on all of those ROMs. I'm completely at a loss for what to do next. Any ideas? Photosphere and panorama are the only things wrong with the stock camera and everything else is fine. It isn't a big deal but would be nice to get it working!
Last edited by dokap; 4th September 2014 at 08:04 AM.
4th September 2014, 03:34 PM   |  #2  
Senior Member
Thanks Meter: 125
 
467 posts
Join Date:Joined: Feb 2009
Quote:
Originally Posted by dokap

Hi guys and gals,

I've never tried to use photospheres or panorama mode on my phone before and decided to give it a whirl yesterday. It didn't work. It was just a gray screen with dots/rectangle telling me to move the circle into the bigger circle. I can move the circle and "gray dot world" around but that's it. My current rom is CM11 official nightlies (I update it every day or two). I've tried reflashing gapps (with the .forcegallery file in place), removing gapps, using the 4.4.4 micro module gapp, the aroma installer for photosphere fix, some other xda thread's JB photosphere zip, reflashing to stock, reflashing to other ROMs, downloading google camera from the play store, and doing all of the previous gapp stuff on all of those ROMs. I'm completely at a loss for what to do next. Any ideas? Photosphere and panorama are the only things wrong with the stock camera and everything else is fine. It isn't a big deal but would be nice to get it working!

Find and install the latest "Banks" GAPPS package. When you DL google cam from the market it doesn't install as system and I think that's the problem.

Ok, just did a search and realized that Banks has stopped making GApps packages but explains a bit in the thread why and gives a pointer. He also says that the zips will be available still for awhile.

http://forum.xda-developers.com/goog...gapps-t2012857

When I used his packages I always had photosphere working.
4th September 2014, 05:27 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2014
Quote:
Originally Posted by dopy25

Find and install the latest "Banks" GAPPS package. When you DL google cam from the market it doesn't install as system and I think that's the problem.

Ok, just did a search and realized that Banks has stopped making GApps packages but explains a bit in the thread why and gives a pointer. He also says that the zips will be available still for awhile.

http://forum.xda-developers.com/goog...gapps-t2012857

When I used his packages I always had photosphere working.

Thanks but unfortunately that hasn't been working. I've been using the 8-11 standard release (and also the gallery/old camera micromodule when that inevitably fails to fix it).
4th September 2014, 07:01 PM   |  #4  
Senior Member
Thanks Meter: 125
 
467 posts
Join Date:Joined: Feb 2009
Quote:
Originally Posted by dokap

Thanks but unfortunately that hasn't been working. I've been using the 8-11 standard release (and also the gallery/old camera micromodule when that inevitably fails to fix it).

You have tried Banks GApps and not PA GApps? Or both?

It very well could be a kernel issue. I am not sure because it has been awhile since I tried CM, but have you tried a different kernel?

Solid kernel or f93 kernel should work with gproj CM11 (that's the official sources used).

It should work on any GEE rom as well but the camera quality is a kind of poor although there is a fix in progress for that.

I would suggest a clean flash, Banks GApps that include the Google camera (standard) and nothing extra as far as camera/gallery and then see what happens.
4th September 2014, 08:29 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2014
Quote:
Originally Posted by dopy25

You have tried Banks GApps and not PA GApps? Or both?

It very well could be a kernel issue. I am not sure because it has been awhile since I tried CM, but have you tried a different kernel?

Solid kernel or f93 kernel should work with gproj CM11 (that's the official sources used).

It should work on any GEE rom as well but the camera quality is a kind of poor although there is a fix in progress for that.

I would suggest a clean flash, Banks GApps that include the Google camera (standard) and nothing extra as far as camera/gallery and then see what happens.

Tried both unfortunately. Thank you for the kernel idea, I hadn't thought of that. I think I will keep an eye out and wait for them to fix the camera quality first because right now my camera is perfect other than the gimicky photosphere thing I wanted to try. I'll try and remember to update this thread to provide a fix when I find it.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes