FORUMS

How to Lock and Protect Your Apps – XDA Xposed Tuesday

The smartphone revolution has passed. Everybody has mobile apps. Some of … more

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

[Q&A] CyanogenMod 11.0 for Photon Q

n/a posts
Thanks Meter: 0
 
By QA Bot, Guest on 12th October 2014, 06:29 PM
Post Reply Subscribe to Thread Email Thread
Q&A for CyanogenMod 11.0 for Photon Q

Some developers prefer that questions remain separate from their main development thread to help keep things organized. Placing your question within this thread will increase its chances of being answered by a member of the community or by the developer. Thanks for understanding and for helping to keep XDA neat and tidy! :smile:
 
 
12th October 2014, 06:29 PM |#2  
Junior Member
Thanks Meter: 0
 
More
CM11 - XT897 WiFi issue
I recently flashed my XT897 with CM11-jbbl and I cannot connect to my WiFi. I did a bit searching but I cannot find a solution. I was hoping someone could point me in the right direction.
12th October 2014, 08:07 PM |#3  
Senior Member
Thanks Meter: 30
 
More
The XT897 uses only 2.4GHz.
It's possible that it also can only connect in channels 1-11. <- needs confirmation, didn't test that.
12th October 2014, 09:29 PM |#4  
Retired Forum Moderator / Recognized Developer
Thanks Meter: 3,722
 
Donate to Me
More
Quote:
Originally Posted by Stupidrak

I recently flashed my XT897 with CM11-jbbl and I cannot connect to my WiFi. I did a bit searching but I cannot find a solution. I was hoping someone could point me in the right direction.

Quote:
Originally Posted by Loader009

The XT897 uses only 2.4GHz.
It's possible that it also can only connect in channels 1-11. <- needs confirmation, didn't test that.

Also, make sure you clean flash.
13th October 2014, 12:26 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by arrrghhh

Also, make sure you clean flash.

By this do you mean wipe everything prior to flashing? If so, then I did so everything should be good.

Thanks for the swift replies.
13th October 2014, 01:21 AM |#6  
Retired Forum Moderator / Recognized Developer
Thanks Meter: 3,722
 
Donate to Me
More
Quote:
Originally Posted by Stupidrak

By this do you mean wipe everything prior to flashing? If so, then I did so everything should be good.

Thanks for the swift replies.

Yes, that's what I mean.... doing at least a factory reset before installing. Wiping /system before flashing is also a good idea, if you're going between custom ROM's and don't want the gapps to be backed up.

Can you explain more about your wifi setup... anything special? What frequency? Encryption type?

Also what happens on the phone?

Have you tried rebooting?

Which CM are you installing - nightly or snapshot? Have you tried different versions?
13th October 2014, 04:18 AM |#7  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by arrrghhh

Yes, that's what I mean.... doing at least a factory reset before installing. Wiping /system before flashing is also a good idea, if you're going between custom ROM's and don't want the gapps to be backed up.

Can you explain more about your wifi setup... anything special? What frequency? Encryption type?

Also what happens on the phone?

Have you tried rebooting?

Which CM are you installing - nightly or snapshot? Have you tried different versions?


Sorry for the lack of details thus far. Here we go:
  • 2.4Ghz WPA-PSK
  • The phone only allows me to input a password and then simply states it has the network info saved. No wifi is connected.
  • I have tried rebooting but no change
  • I have attempted to wipe the wifi settings in the data folder but no changes
  • I have reviewed my routers settings and changed the broadcast channel as well as the frequency.
  • I have tried using two releases so far for the moto_msm8960_jbbl rom. 10-08 snapshot and the 10-11 Nightly.
13th October 2014, 11:38 AM |#8  
Senior Member
Thanks Meter: 30
 
More
Which channel is your AP using?
Is your AP hidden?

AP = Access Point = WLAN-Router

Also, what happens if you tap on the AP (on the PQ) and select "connect"?
13th October 2014, 03:23 PM |#9  
Junior Member
Flag Berlin
Thanks Meter: 1
 
More
try to switch to WPA2-PSK , I did read somwhere that this could be the issue.
24th October 2014, 12:48 PM |#10  
Senior Member
Thanks Meter: 30
 
More
I managed to find a "problem" or "bug" (or "missfunction of the SoC/driver") by accident.
When I try to rebuild a thumbnail for one video (with MX Player), the landscape mode is malfunctioning.
If I force close MX Player (in portrait mode), the malfunction doesn't go away. (Landscape mode is "crippled".)
I have to do a cold boot.

I have a log with "only" crippled landscape mode: (the [...] represents the line before for a dozen times; 10-300 times)
Code:
10-24 13:03:15.239 W/ResourceType(7029): Invalid package identifier when getting bag for resource number 0xffffffff
10-24 13:03:16.721 W/Adreno200-GSL(1473): <gsl_ldd_control:359>: ioctl fd 15 code 0xc0140910 (IOCTL_KGSL_RINGBUFFER_ISSUEIBCMDS) failed: errno 22 Invalid argument
[...]
10-24 13:03:16.731 I/configuration_changed(7029): 1152
10-24 13:03:16.721 W/Adreno200-GSL(1473): <gsl_ldd_control:359>: ioctl fd 16 code 0xc0140910 (IOCTL_KGSL_RINGBUFFER_ISSUEIBCMDS) failed: errno 22 Invalid argument
[...]
10-24 13:03:16.731 I/ActivityManager(7029): Config changes=480 {0.90000004 262mcc7mnc de_DE ldltr sw360dp w598dp h334dp 240dpi nrml land finger qwerty/v/h dpad/h s.16 themeResource=null}
10-24 13:03:16.741 I/InputReader(7029): Reconfiguring input devices.  changes=0x00000004
10-24 13:03:16.741 I/InputReader(7029): Device reconfigured: id=1, name='atmxt-i2c', size 540x960, orientation 3, mode 1, display id 0
10-24 13:03:16.741 I/InputReader(7029): Reconfiguring input devices.  changes=0x00000004
10-24 13:03:16.801 D/PhoneStatusBar(10288): mSettingsPanelGravity = 55
10-24 13:03:16.801 W/Adreno200-GSL(1473): <gsl_ldd_control:359>: ioctl fd 15 code 0xc0140910 (IOCTL_KGSL_RINGBUFFER_ISSUEIBCMDS) failed: errno 22 Invalid argument
[...]
10-24 13:03:16.841 D/GeckoApplication(10638): onConfigurationChanged: de_DE, background: false
10-24 13:03:16.841 D/GeckoLocales(10638): No selected locale. No correction needed.
10-24 13:03:16.841 W/Adreno200-GSL(1473): <gsl_ldd_control:359>: ioctl fd 15 code 0xc0140910 (IOCTL_KGSL_RINGBUFFER_ISSUEIBCMDS) failed: errno 22 Invalid argument
[...]
10-24 13:03:17.021 I/Timeline(7029): Timeline: Activity_windows_visible id: ActivityRecord{42ba64a0 u0 com.nolanlawson.logcat/.LogcatActivity t3} time:813069
10-24 13:03:17.021 W/Adreno200-GSL(1473): <gsl_ldd_control:359>: ioctl fd 15 code 0xc0140910 (IOCTL_KGSL_RINGBUFFER_ISSUEIBCMDS) failed: errno 22 Invalid argument
[...]
10-24 13:03:17.422 I/WindowManager(7029): Screen frozen for +786ms due to Window{42bdeeb0 u0 StatusBar}
10-24 13:03:17.462 W/Adreno200-GSL(1473): <gsl_ldd_control:359>: ioctl fd 15 code 0xc0140910 (IOCTL_KGSL_RINGBUFFER_ISSUEIBCMDS) failed: errno 22 Invalid argument
[...]
10-24 13:03:18.002 I/InputReader(7029): Reconfiguring input devices.  changes=0x00000004
10-24 13:03:18.002 I/InputReader(7029): Device reconfigured: id=1, name='atmxt-i2c', size 540x960, orientation 0, mode 1, display id 0
10-24 13:03:18.012 I/ActivityManager(7029): Config changes=480 {0.90000004 262mcc7mnc de_DE ldltr sw360dp w360dp h566dp 240dpi nrml port finger qwerty/v/h dpad/h s.17 themeResource=null}
10-24 13:03:18.002 I/configuration_changed(7029): 1152
10-24 13:03:18.062 D/PhoneStatusBar(10288): mSettingsPanelGravity = 55
10-24 13:03:18.092 D/GeckoApplication(10638): onConfigurationChanged: de_DE, background: false
10-24 13:03:18.102 D/GeckoLocales(10638): No selected locale. No correction needed.
10-24 13:03:18.403 I/Timeline(7029): Timeline: Activity_windows_visible id: ActivityRecord{42ba64a0 u0 com.nolanlawson.logcat/.LogcatActivity t3} time:814439
10-24 13:03:18.753 I/WindowManager(7029): Screen frozen for +775ms due to Window{42bdeeb0 u0 StatusBar}
10-24 13:03:18.783 W/Adreno200-GSL(1473): <gsl_ldd_control:359>: ioctl fd 15 code 0xc0140910 (IOCTL_KGSL_RINGBUFFER_ISSUEIBCMDS) failed: errno 22 Invalid argument
[...]
10-24 13:03:19.173 E/ViewRootImpl(10781): Attempting to destroy the window while drawing!
10-24 13:03:19.173 E/ViewRootImpl(10781):   window=android.view.ViewRootImpl@42348bf8, title=Toast
10-24 13:03:19.254 W/ResourceType(7029): Invalid package identifier when getting bag for resource number 0xffffffff
10-24 13:03:19.264 I/sf_frame_dur(1473): [Toast,13,0,1,0,0,0,1]


If you need a log, when I redo the "bug" or "malfunction", please say so.
This bug has to be for a few month in CM11 now. I noticed it earlier but I didn't manage to repeat it.


PS: Please keep in mind, that this might be a faulty device. I have random reboots and after a reboot, the phone-function doesn't work. I have to cold boot several times.
Also the WLAN seems to hang, but this might be the fault of titanium backup. I tested it and it hung everytime it backups the WLAN-data (because of this, WLAN is no longer backed up).
Post Reply Subscribe to Thread

Tags
auto-qa
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes