Post Reply

[TUTORIAL] Permanently Fix IMEI problem in xolo q1010i

OP Reconfigured

29th August 2014, 06:14 PM   |  #1  
Reconfigured's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 39
 
197 posts
Join Date:Joined: Aug 2011
Donate to Me
More
First of all...

____/\_____ MAUI META by MediaTek....

finally managed to permanently fix the erasing problem of imei on flashing new ROM or factory resetting phone ....

mobile uncle tools or... engineering mode temporarily fixes the imei problem by pasting what's known as "Soft Imei" and which tends to get erased on formatting or flashing new ROM .

also in KitKat the security is so optimized that engineering mode doesn't accepts the imei

now this method I'm sharing with you permanently fixes the problem of accidentally formatting NVRAM using sp tools.

Things you need

NVRAM DB FILE MT6582 : http://www.4shared.com/rar/vbnwUC_ab...2_DB_File.html
__________________________________________________ ____
MAUIMETA TOOLS:
http://www.mediafire.com/download/79...NESIA+RAYA.rar
__________________________________________________ ____
DRIVERS
CDC :
http://www.mediafire.com/download/yx...CDC_driver.rar
__________________________________________________ ____
MTK65xx ADB VCOM Driver :
http://www.4shared.com/rar/OK3bRxzXb...roid_ZTE_.html

now follow these steps:
1> install all necessary drivers.
2> install MauiMeta software.
3> turnoff the phone.
4> open Maui software goto option and select " Connect Smart Phone Into A Meta Mode" and hit reconnect
5> connect the phone in off mode.
6> it will detect and then on upper left corner tab select "Write Imei" option a new window will open.
7> click on "Change Nvram Database File" and select BPLGU file from MT6582_DB file.rar after extracting it.
8> Now just write 14 digit imei imprinted on back of your phone and 15th digit will be automatically generated for both Sim's.
9> Press download to Flash.
10> close that tab and hit disconnect.
......TaDa......
problem solved....
now flash any ROM or factory reset it imei will be automatically recovered ...

I'll rewrite this post soon after i renew my internet with snapshots till then ask any questions here.
.
Press Thanks if I Helped you...
Attached Images
File Type: jpg pic1.jpg - [Click for QR Code] (24.9 KB, 179 views)
File Type: jpg pic2.jpg - [Click for QR Code] (64.3 KB, 124 views)
File Type: jpg pic4.jpg - [Click for QR Code] (89.1 KB, 111 views)
Last edited by Reconfigured; 4th September 2014 at 01:16 PM.
The Following 10 Users Say Thank You to Reconfigured For This Useful Post: [ View ]
30th August 2014, 05:16 PM   |  #2  
Raj Rohit's Avatar
Member
Flag Bangalore
Thanks Meter: 27
 
63 posts
Join Date:Joined: Apr 2012
More
Great Work Bro...
SALUTE...

---------- Post added at 09:46 PM ---------- Previous post was at 09:45 PM ----------

Great Work Bro...
SALUTE...

But i still have to try....
1st September 2014, 06:29 PM   |  #3  
Reconfigured's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 39
 
197 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Quote:
Originally Posted by Raj Rohit

Great Work Bro...
SALUTE...

---------- Post added at 09:46 PM ---------- Previous post was at 09:45 PM ----------

Great Work Bro...
SALUTE...

But i still have to try....

just press thanks buddy...
3rd September 2014, 11:11 PM   |  #4  
ryanaepple's Avatar
Junior Member
Flag indonesia - palembang
Thanks Meter: 20
 
25 posts
Join Date:Joined: May 2013
More
Thumbs up its works
Quote:
Originally Posted by Reconfigured

First of all...
.
____/\_____ MAUI META by MediaTek....
.
finally managed to permanently fix the erasing problem of imei on flashing new ROM or factory resetting phone ....
.
mobile uncle tools or... engineering mode temporarily fixes the imei problem by pasting what's known as "Soft Imei" and which tends to get erased on formatting or flashing new ROM .
.
also in KitKat the security is so optimized that engineering mode doesn't accepts the imei
.
now this method I'm sharing with you permanently fixes the problem of accidentally formatting NVRAM using sp tools.
.
Things you need
.
NVRAM DB FILE MT6582 : http://www.4shared.com/rar/vbnwUC_ab...2_DB_File.html
..................
MAUIMETA TOOLS : http://www.mediafire.com/download/79...NESIA+RAYA.rar
................
DRIVERS
CDC : http://www.mediafire.com/download/yx...CDC_driver.rar
.................
MTK65xx ADB VCOM Driver : http://www.4shared.com/rar/OK3bRxzXb...roid_ZTE_.html
.
now follow these steps:
1> install all necessary drivers.
2> install MauiMeta software.
3> turnoff the phone.
4> open Maui software goto option and select " Connect Smart Phone Into A Meta Mode" and hit reconnect
5> connect the phone in off mode.
6> it will detect and then on upper left corner tab select "Write Imei" option a new window will open.
7> click on "Change Nvram Database File" and select BPLGU file from MT6582_DB file.rar after extracting it.
8> Now just write 14 digit imei imprinted on back of your phone and 15th digit will be automatically generated for both Sim's.
9> Press download to Flash.
10> close that tab and hit disconnect.
......TaDa......
problem solved....
now flash any ROM or factory reset it imei will be automatically recovered ...
.
I'll rewrite this post soon after i renew my internet with snapshots till then ask any questions here.
.
Press Thanks if I Helped you...


Awesome..
Thanks Dude
i have try on Device base MT6572 work like charm
file BPLGU take by stock rom ..
now i'm free
4th September 2014, 01:18 PM   |  #5  
Reconfigured's Avatar
OP Senior Member
Flag Mumbai
Thanks Meter: 39
 
197 posts
Join Date:Joined: Aug 2011
Donate to Me
More
Angry
Quote:
Originally Posted by ryanaepple

Awesome..
Thanks Dude
i have try on Device base MT6572 work like charm
file BPLGU take by stock rom ..
now i'm free

Happy to help....
4th September 2014, 05:46 PM   |  #6  
Senior Member
Flag Leeds
Thanks Meter: 8
 
150 posts
Join Date:Joined: Mar 2010
Will this help my problem? I have a Lenovo S850 MTK 6582. I have written the imei's back and it sees my sim card but no mobile signal. If I factory restore I loose imei and nvram warning back. But its the no signal even after imei is present I dont understant.
4th September 2014, 06:21 PM   |  #7  
andro2master's Avatar
Member
Flag Navi Mumbai
Thanks Meter: 16
 
67 posts
Join Date:Joined: Oct 2012
More
Quote:
Originally Posted by waj1234

Will this help my problem? I have a Lenovo S850 MTK 6582. I have written the imei's back and it sees my sim card but no mobile signal. If I factory restore I loose imei and nvram warning back. But its the no signal even after imei is present I dont understant.

Are you entering the exact IMEI which is mentioned on box / package provided with your mobile? If yes then you should get network access. You can check IMEIs with service provider if problem is not solved.
Best of Luck.
4th September 2014, 06:27 PM   |  #8  
Senior Member
Flag Leeds
Thanks Meter: 8
 
150 posts
Join Date:Joined: Mar 2010
Quote:
Originally Posted by andro2master

Are you entering the exact IMEI which is mentioned on box / package provided with your mobile? If yes then you should get network access. You can check IMEIs with service provider if problem is not solved.
Best of Luck.


Yes imei numbers are correct. I just connected to the tool listed here and it shows bands below connected with target window. It lists GSM 850, GSM 900, DCS1800, PCS1900, BAND 1, BAND 8.

Does that seem correct? 3g UK is 2100 but its not listed. I have the latest correct firmware with the correct baseband.
4th September 2014, 06:31 PM   |  #9  
andro2master's Avatar
Member
Flag Navi Mumbai
Thanks Meter: 16
 
67 posts
Join Date:Joined: Oct 2012
More
I will suggest you to check band frequencies first with your Service provider. Otherwise try and use engineering mode of MTK device to try enable various bands in operations.
Best of Luck
4th September 2014, 06:47 PM   |  #10  
Senior Member
Flag Leeds
Thanks Meter: 8
 
150 posts
Join Date:Joined: Mar 2010
Quote:
Originally Posted by andro2master

I will suggest you to check band frequencies first with your Service provider. Otherwise try and use engineering mode of MTK device to try enable various bands in operations.
Best of Luck

I have checked in engineering mode on my s939 and this s850 and both have same bands ticked and the 3g works fine on my s939. Just no idea why s939 works but s850 will not with same sim card. Tried 2 different sims in it and its just same so not the sim card.

Post Reply Subscribe to Thread

Tags
corrupted nvram, flash imei, invalid imei, nvram, xolo q1010i
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Q1010i Android Development by ThreadRank