Default Bricked my phone... Please help

Hello,
i was looking out for a method to root my xolo q1010i(KITKAT) and hence flashed custom recoveries on it..
First i flashed carliv touch recovery and it got successfully flashed but i was unable to install zip file(SuperSU zip) through recovery.
i got the following error:-
E: Can't mount /cache/recovery/command
E: Can't mount /cache/recovery/log
E: Can't open /cache/recovery/log
E: Can't mount /cache/recovery/last_log
E: Can't open /cache/recovery/last_log
I thought it was the recovery so i flashed CWM recovery but same error showed up while installing zip and then i flashed TWRP recovery but to no avail. it also gave me the same error. so i decided to flash stock rom and hence i downloaded the stock ROM for my device from the internet and flashed it but after flashing it i started getting bootloop(Phone got stuck on the XOLO logo)..
i was very frustrated and i accidentally formatted it through sp flash tool's FORMAT tab and auto format option(Format whole flash except bootloader) and after formatting my phone i tried connecting it to PC but it doesn't gets detected in my PC and therefore i cannot flash any ROM on it..
Please help me as i bought this phone 12 days back and i have lost my warranty as i bricked it..
Thanks in advance..