Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Need help - Stuck on static red logo

OP harroxelas

11th July 2014, 12:54 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Mar 2013
Hi all,

I was browsing the web on dolphin browser and my XT890 simply froze. After 5 minutes, I held the power button + volume down + volume up and the phone rebooted, but it got stuck on the red M static logo. Had to open the phone and disconnect the battery connector from the PCB so I could turn it off. Here are the facts:

1) Stock rom, 4.1.2 JB;
2) Can't get into fastboot menu;
3) With the phone turned off, after connecting the battery charger I can see the battery charging screen.

Because of 3) above, I don't think the phone is dead. Can any of you guys help me?

Thanks in advance.
11th July 2014, 01:47 AM   |  #2  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Mar 2013
Update:

Managed to get into fastboot. Did a wipe data / factory reset but after rebooting, it still got stuck on the static red logo.

Will flashing the stock rom again with RSD do the trick?

Thanks in advance
11th July 2014, 09:47 AM   |  #3  
Hazou's Avatar
Senior Member
Thanks Meter: 1,009
 
740 posts
Join Date:Joined: Feb 2012
Donate to Me
More
If u have access to the recovery, than a full flash with rsd lite will help (almost always) Do use the latest version of your firmware if JB has been installed on your phone. When JB hasn't been installed on your device, than any firmware can be flashed.
15th July 2014, 02:57 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Mar 2013
Quote:
Originally Posted by Hazou

If u have access to the recovery, than a full flash with rsd lite will help (almost always) Do use the latest version of your firmware if JB has been installed on your phone. When JB hasn't been installed on your device, than any firmware can be flashed.

Thanks, mate. Flashing worked.

I just noticed that the SD card does not work anymore, probably that's what caused the crash in the first place. Replaced the SD card and it's working ok for now.

Cheers.
23rd July 2014, 08:16 PM   |  #5  
Member
Thanks Meter: 2
 
37 posts
Join Date:Joined: Dec 2010
Hi,

I've exactly the same problem. Went to shut down the phone and it hung. Power and vol down to reset and the static red logo. I can get into fast boot and even android recovery but factory reset and full data wipe have no effect.

Could I flash a rom from android recovery? If so which one (phone was updated to JB a year or so ago). Otherwise do I need to use RSD lite when I get to a PC?

Is the internal sd card a standard micro SD card?

Many thanks,

Nick
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes