Default Credential Storage Issues for Exchange Certificates

I am having a lot of trouble with the stability of the Credential Storage on the Shield Tablet. Specifically, with storing and accessing .pfx client certificates for corporate mail.

=Summary=
When I initially load a .pfx file and unlock it with the correct password, it lets me connect to the Active Sync mail service. After the initial sync things begin to go bad.

=Steps to Reproduce=

1. Go to any ActiveSync compatible mail client (9folders, Stock Android mail client) and add a .pfx certificate.
2. Go through the account set-up process and add the account.
3. Let the app perform the initial sync.
4. Begin making changes to mail status in the app (delete mail, mark read).
5. Force a refresh and observe results.

=Actual Results=

After the initial mail sync, the client certificate associated with the mail client is wiped from the profile. This happens in stock android email (Corporate Mail) and 9Folders.

The message "No Connection" displays because the mail client certificate is wiped from the profile, and the mail client doesn't have blessing to connect to the server.

=Expected Results=

The client certificate remains in force after the initial sync event, and continues to work as expected.

=Additional Info=

I have, on several occasions now, deleted the entire credential storage, and restarted the tablet, then re-added the same certificate again.

The same behaviour consistently happens over and over again. It is like something is going wrong with the credential storage in the build the Shield Tablet is using.

This has been an issue since I first got the tablet, and has not be resolved with the recent update to Stock 440 build.