Find Your Device:
Or Continue to Thread: [DEV] System images
14th June 2011, 02:36 PM |#146  
spaanplaat's Avatar
Senior Member
Flag Roosendaal
Thanks Meter: 7
Thumbs up Acer_A500_1.105.01_EMEA_GEN3 boot.img, flexrom.img, system.img and
Ok, I extracted the boot system and flexrom from my brothers A500 which has Acer_A500_1.105.01_EMEA_GEN3 (unzip to see the, flexrom.img, boot.img and system.img).

Download here.

Let me explain what I did to restore mine to stock.

First I bricked my device but thanks to the from this thread I was able to recover it.

Next I flashed the system.img and flexrom.img with the following commands in ADB

Important: in this order!

ADB shell
dd if=/sdcard/flexrom.img of=/dev/block/mmcblk0p6
(takes about 30 secs, 100 MB)
dd if=/sdcard/system.img of=/dev/block/mmcblk0p3
(takes a couple minutes, it's 600 MB)

First I tried to flash the boot.img also but this resulted in an LNX checksum error during start-up and had to re-apply the So don't do this.
After the flexrom.img and system.img were flashed I rebooted the A500. Note: the A500 will be unresponsive after flashing system.img so you have to reboot manually (holding power button).

I was able to select the proper language (Dutch in my case). But wifi wasn't working so I had to make this working again using these files (depending on your kernel). You can restore wifi using this post. You might need to run gingerbreak again for root.

After that was working I was given the option to update . I tried the update but it failed due to the boot.img. I rebooted the A500 and flashed the boot.img using ADB with this command.
ADB shell
dd if=/sdcard/boot.img of=/dev/block/mmcblk0p2
(takes a couple seconds, only 8 MB)

After it is finished do not reboot!!.

Then I ran the update and it was successful. Tadaa stock A500 with firmware Acer_A500_1.141.01_EMEA_GEN3.

In any case your device doesn't offer you the update I included it with the download. The came from this post. In that case I would think you first flash boot.img and then reboot with the vol - button pressed while on your EXT_SD.

I hope this will help some people.
Last edited by spaanplaat; 14th June 2011 at 03:28 PM. Reason: add info