Nice work bro.although it would be better to use the latest a2sd version of darktremor(2.7.5.3)
which supports ext4 partition and data2sd feature.so instead of adding a2sd 2.7.5.2 you can provide a link to the flashable zip of the latest DT-a2sd (http://www.darktremor.info/files/a2s...a04-signed.zip). it works i have tested it.