Or Continue to Thread: [FIX][CWM]Rotation lag fix for…
Find Your Device:
14th November 2011, 10:33 PM   |  #72  
Senior Member
Flag Longview, TX
Thanks Meter: 95
 
264 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by chris41g

Tested on EF02 with cwm 3.1.0.1

First flash the zip... it gives you about 8 seconds to lay the phone on a flat surface after hitting yes to flash the zip...

then some framework edits will need to be made....

Code:
    .prologue
    .line 54
    const/4 v0, 0x3
needs to be changed to
Code:
    .prologue
    .line 54
    const/4 v0, 0x2
if you have a framework.jar that has been modified, make the edits, if you are stock here is a stock deodexed framework.jar edited..
http://www.forums.acsyndicate.net/sh...tation-Lag-Fix

Chris, I'm stumbling around trying to figure out a rotation-lag fix for CM7. Can you give me any pointers? I've read this topic and smali'd my "framework.jar" but there is no ".line 54" in the framework.jar that comes with CM7. What else would I be looking for in that file, or where would I find what to look for? I did find
Code:
.method public constructor <init>(Landroid/content/Context;)V
    .registers 3
    .parameter "context"

    .prologue
    .line 67
    const/4 v0, 0x3

    invoke-direct {p0, p1, v0}, Landroid/view/WindowOrientationListener;-><init>(Landroid/content/Context;I)V
which is the closest to what you posted and if you think that may be the correct section I'll try changing the "0x3" to read "0x2". What are your thoughts?