Or Continue to Thread: [FAIL] ### BOOTLOADER UNLOCK #…
Find Your Device:
11th January 2012, 03:53 PM   |  #32  
OP Recognized Developer
Flag Torino
Thanks Meter: 3,804
 
2,247 posts
Join Date:Joined: May 2007
Donate to Me
More
We've examinated with Skrilax_CZ (Thanks man!) the whole situation and unfortunately we've discovered that the bootloader we've got is only a different one.

We still don't know with precision in what does it differ, it shows "Factory Use Only" on Fastboot Mode and it is SIGNED, so it can be flashed on retail RAZRs without any problem, but still, the unlock procedure is disabled and it can't be enabled.

We've tried multiple ways 'til now and I'm sorry to say that: nothing to do. It wasn't of any help.


I can't explain more on the things we've tried, but the bad thing is that the guy where we've taken the bootloader from has got a really strange device, it is a RETAIL EU device but its OMAP4430 is soldered in GP Mode (like the Engineering phones), so its security is disabled by eFuse.

I can explain just one thing for you, as I feel somehow in debt with you all because I've raised everyone's hopes in that thing:

When the bootloader is loaded, it first checks for a value of an eFuse. If the eFuse that determines the device security (RETAIL or ENGINEERING) is blown it is recognized as RETAIL. If it isn't blown it is recognized as ENGINEERING.
Our eFuse is set to RETAIL, so that the bootloader checks other eFuses to determine if the device has been manually unlocked or not.
That guy's eFuse is set to ENGINEERING, so that the bootloader won't check other eFuses and goes on directly with the UNLOCKED status.


That guy's device isn't an engineering one because other parameters of its device doesn't correspond to an engineering device. It's a really strange device, but something is different on the hardware side: we don't know if its OMAP is soldered to GP or HS Mode, but we're sure its eFuse is set to ENGINEERING and, unfortunately, the fuses cannot be blown TWO times because they're One Time Programmable "memories", so we cannot reprogram our fuse.


I would like to really say thanks to adlx.xda for his device's dumps and to those who trusted us and gave us the possibility to test it on their devices with a good chance of hardbricks. (Sorry if I don't say your nicknames guys, we've talked on GTalk and I can't clearly remember your xda nicknames!)
Thanks guys, without you, we would have never known the truth on this.


Oh, another word to the testers. Please, don't make this bootloader to be public prior I will: I don't know if WE CAN upload it to the public or not.



As for now, I'm sad to announce that this TEST has been failed.
This thread will be closed in an hour or so.



The EternityProject Team Manager,
--kholk
Last edited by kholk; 11th January 2012 at 04:27 PM.
The Following 16 Users Say Thank You to kholk For This Useful Post: [ View ]