Manually updated to 6.2.2. In the process of trying to regain root, and when I get to this line:

adb shell 777 /data/local/BurritoRoot2.bin

I get

777: permission denied

If I type this:

adb shell ls /data/local/

I see BurritoRoot2.bin, so I know it got pushed correctly. The adb shell chmod command ran with no feedback. I re-ran it and still can't get past this. Any suggestions?

edit: I got through it. I ran this line instead of the 777 line:

adb shell ./data/local/BurritoRoot2.bin

And it told me to proceed. I'll post back if I'm successful.

edit2: that worked - everything else ran correctly (other than installing Superuser.apk, because it already still existed). When I fired up Titanium Backup Pro, it says I'm rooted still. Huzzah. Superuser app FCs for some reason but even after rebooting, TiBackup still says it's root. Weird.

edit3: probably would have been better if I'd done a factory wipe before installing 6.2.2 through TWRP. Had to temp-root after rebooting and uninstall (adb shell rm) su and Superuser, then reinstall them. Now Superuser doesn't crap out on me when apps ask for root access. Annoying but not unobtainable. Again, thanks jcase for all you do.