Or Continue to Thread: CUBE U9GT2 Android 4.0.3 Mods
Find Your Device:
26th March 2012, 08:10 PM   |  #568  
wackym's Avatar
OP Member
Thanks Meter: 107
 
46 posts
Join Date:Joined: Dec 2010
Quote:
Originally Posted by wnfrd

Is there any chance of getting support for bluetooth sticks in the modded firmware? ICS kernel source code is available for easypix's variant of the Cube U9GT2 at http://www.easypix.info/download/eas...e_android4.zip (16/Mar/2012), in case that helps. I'm looking for support for the serial bluetooth profile.

Thanks for the tip on kernel! I successfully recompiled it and tested cifs module.
I'm currently struggling to compile the BT support...try these modules:
http://www.mediafire.com/?7yv9833v9n87kat
You'll probably need to "cherry pick" them...


Quote:
Originally Posted by sw6lee

Does anyone know when our tablet android 4.0 firmwares will be finally smooth? The home screen is choppy, but when turn off the wallpaper scrolling, its significantly better. Also, I think they left out some of Honeycombs bugs, I don't know how, because they are all already fixed in ice cream sandwich by google. I have acer iconia a500 so I know. First one is the keyboard lag within web browser. It lags like hell, just like honeycomb. And also, the recent app button in the navigation bar lags when there are a lot of apps to show. It should be instant in ics. It lagged in honeycomb though. Not to mention the scrolling and slide to close is very choppy too. These two are both fixed in ice cream sandwich, but this firmware still has the bugs. And this one is not related to honeycomb, but the notification tray lags when trying to open while somethings running. What is 1gb of ram for?? So if anybody can speak chinese can they find out when these bugs are going to be ironed out and when the whole system will become smooth by asking Cube or Window, or Rockchip?
Thanks.

This is wishful thinking That's all I can say... I sincerely hope that M$ doesn't make the same mistake that google did - use virtualized software for UI.

Quote:
Originally Posted by jvinga1

I see that the keyboard is still missing a proper dictionary, so spell suggestions are missing when typing and spell correction causes words to be underlined in red in email and other apps.
I used Fryesg's link to latinIMEGoogle.apk to install another copy of the keyboard, then selected it as default and set it for the one to use for spell check, but I'd really like to see this fix incorporated.
Wackym, I see a note for 1.07 (I think) that says this is fixed, but it doesn't seem to be. Can you, or someone confirm that this is still an issue?
I found another thread with a link to just latinIME.apk (no Google in the name) that will temporarily fix it if installed, but the fix disappears after a reboot.
Can anyone else confirm the same?
Wackym, can you comment on this?

Well, I thought I fixed it...I'll try to do better...

Quote:
Originally Posted by akeilox

Hi wackym
I noticed the Ethernet settings, that used to be under Settings in gingerbread versions, is missing in the ICS builds.
I have the typical ASIX based (asix.ko) USB to ethernet adapter that I would like to use with the few tablets (U9GT2) and cant seem to locate any article or source on how to enable the Ethernet under Settings back on and use an updated asix.ko (compiled for the latest ICS kernel).
I understand very briefly someone released a patch to enable the Ethernet under Settings on ICS but its a russian site and translation doesnt read that well (filename they quoted is ethernet.diff.tar.gz for the ICS builds but for a different tablet).
I have tried to setup an ICS build environment following the article at www dot freeyourandroid.com/guide/compile-ics but stucked at section 5 "Obtaining proprietary binaries" and realized the RK2918 binaries are not available under google code.
Would you be able to help me to enable the Ethernet back on the latest ICS builds, or guide me on the right direction to get pass section 5 at article www dot freeyourandroid.com/guide/compile-ics

I simply need an re-compiled ASIX.ko file for the latest kernel and a way to enable the Ethernet on the latest ICS Settings section.

Many thanks in advance

EDITED:
The driver source for the ASIX usb ethernet is located at
www dot asix.com.tw/products.php?op=pItemdetail&PItemID=97;71;101

under Drivers;
Linux kernel 3.x/2.6.38 (v4.2.0) 2011-09-19 For Android 1.x/2.x/3.0, Linux kernel 2.6.14 and later

FURTHER EDITED:
I have located a web page on Android x86 port related page, where the developer post an update for Ethernet support to the ICS builds.
Not sure if it will be of any help...

www at android-dev.ro/2012/02/22/android-x86-virtualbox-support/

Try these modules: http://www.mediafire.com/?ek31sgyd4j99q1r
You can load these modules via "insmod" command (from adb shell) or with Mount Manager (or similar) app from market.


Quote:
Originally Posted by dieucmoi

Hi wackym !
I've bought my tablet 1 week ago when I was in china and I'm very happy with it.
I'm still discovering its capacity and for the moment no regrets.
I managed to flash your room (1.08) without any troubles !
Everything works so far.

Unfortunately, I have one major issue : The screen is flickering and not very usable (inconsistant) while the tablet is charging.
Apparently you noticed this problem before and fixed it with 1.07 (not tested).
Do you have an idea ?

P.S. (Due to this problem I have to stop to play with it when batteries are empty, that's actually a good thing for my wife )

You could try the insulation trick...to prevent charger tip touching the housing...for me this got fixed by itself with 1.07 mod...but I don't know why.


----------------------------------------------------------------------------------------

For all who wish to have CIFS (SMB/Windows share) support:
http://www.mediafire.com/?7iv3auqdzs6da9r
You can load modules with Mount Manager... I will also add autoloading of these modules in my next mod.
The Following 5 Users Say Thank You to wackym For This Useful Post: [ View ]