I also got the call issue during incoming calls (NO problem in outgoing calls) and if I remember correctly, I got this annoying issue after I got the ForceClose for Phone application... The only solution is double clicking loud-speaker button (enable and disable)...

Now back to Osimood ROM... But surely will return when this bug gets cleared.... Thanks for this great ROM dman...