For all who have the callscreen problem, try to disable automatic lightning

Sent from my legend using XDA