Or Continue to Thread: [KERNEL][SEP.30]Bricked-Kernel…
Find Your Device:
9th May 2012, 02:21 PM   |  #139  
show-p1984's Avatar
OP Recognized Developer
Thanks Meter: 11,443
 
3,330 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Quote:
Originally Posted by wolfraim

1 restart on call ... When VR starts, the call start again automatically... Is this normal? Haha

Can't confirm this on InsertCoin 4.3.0 & 5.1.0.
Log?
Quote:
Originally Posted by yepayepa

Nice to see my One X running bricked, thanks Showp.

Just one problem, if phone was sleeping and a phone call happens, screen turns on, but digitizer seems off (no touch screen)

Cheers.

Can't confirm this either.
Log?
Quote:
Originally Posted by AliceXES

A. Thank you!
B. Is there any reason why you're not compiling modules into kernel?

Yeah, kernel partition is 8192kbytes, the kernel + ramdisk take up 4162kb and the modules would require additional 25.9 Megabyte
Quote:
Originally Posted by Giblet-dono

Here is your confirmation number: 9K83629777053390C

Thanks for you hard work.
I've loved your kernel for the Sensation, now the One x!
I hope to see great things from you in the future!
Keep up the good work!

Giblet

Thank you very much!
Quote:
Originally Posted by nobnut

XDA-downloaders.com

Made my day
Quote:
Originally Posted by listentochaos

Just wanted to give my 2 cents.

Seems to be running very smoothly on ARHD 5.1.1. The Swipe to Wake feature is very useful.

One thing i have noticed is the Menu/Recent Apps soft button unlocks the phone from the lock screen. Is this a feature or bug?

That is a feature from your rom / tweaks app.
Quote:
Originally Posted by truemagic

Works great, in deep sleep, it seems I need to sweep the buttons twice to wake the phone.

And I just had a random reboot in lockscreen after I pressed Home button few times and it hanged and rebooted.

Otherwise a perfect kernel

Thanks bro.

Can't seem to reproduce that either.
Log?
Quote:
Originally Posted by poofish

Sorry if this concern has been covered in show-p's previous releases, but I've come from an SGS2 without sweep2wake so have no previous knowledge of this feature.

I was wondering whether it has a material impact on battery life through wakelocks or such (sort of like how BLN on SGS2 did), as it would mean the capacitive buttons are constantly 'on.'

Can anyone who's used a kernel with sweep2wake shed some light on this?

The touchscreen will be kept online when the phone goes to sleep. That does not mean that there is some fancy algorithm running, it is just online as in: TV Standby. (I would guess that it uses a maximum of 1 % battery on a weeks runtime )
If you touch the screen with capacitive material (eg: your finger) an interrupt will be sent to the kernel and wake up the phone from deep sleep to allow getting positioning data from the touchscreen.
So: No wakelocks and no additional drain if you don't touch your screen when your phone is sleeping

Quote:
Originally Posted by blueacidic

Not sure if it is a bug, I tried left -> right, then right -> left without lifting my fingers off throughout, then when you try to unlock using left -> right, nothing happens, does it happen to any of you?

The touch driver is a bit bitchy right now, I am already looking into this.
Quote:
Originally Posted by AliceXES

PATCH
I'm new to the git thingie so please apply the following patches.
Errors got to surface when I disabled most of debugging (should provide some performance improvements).

Code:
--- drivers/media/video/tegra/tegra_dtv.c~      2012-05-09 15:33:11.131000116 +0300
+++ drivers/media/video/tegra/tegra_dtv.c       2012-05-09 18:18:10.212000301 +0300
@@ -737,7 +737,7 @@
        debugfs_remove(dtv_ctx->d);
 }
 #else
-static int dtv_debugfs_init(struct tegra_dtv_context *dtv_ctx) { return 0 }
+static int dtv_debugfs_init(struct tegra_dtv_context *dtv_ctx) { return 0; }
 static void dtv_debugfs_exit(struct tegra_dtv_context *dtv_ctx) {};
 #endif

not sure about how correct is this one... but i think it's ok.
Code:
--- drivers/usb/gadget/u_serial.c~      2012-05-09 15:33:12.366000116 +0300
+++ drivers/usb/gadget/u_serial.c       2012-05-09 18:22:35.281999968 +0300
@@ -1331,7 +1331,7 @@
        debugfs_create_file("reset", 0222, dent, ui_dev, &debug_rst_ops);
 }
 #else
-static void usb_debugfs_init(struct gs_port *ui_dev) {}
+static void usb_debugfs_init(struct gs_port *ui_dev, int port_num) {}
 #endif

 /**

First of all thanks for your contributions, but I fail to see how those fixes should improve performance.
Furthermore is the first fix only a look and feel formality since there is no semicolon required.
Quote:
Originally Posted by nobnut

So far I have been unable to get the 204, 102 and 51 MHz frequencies. Lots of reboots and testing. No problem with deep sleep.

Is it set this way intentionally, or is this a bug?

Yeah, this is the reboot fix. For some reason putting the clock further down results in an instant reboot atm since the pointers are not set. Looking into that too atm.
Quote:
Originally Posted by tids2k

any plans for an AOSP kernel mate ?

First let me fix up the kernel, ok?
Quote:
Originally Posted by pdagenius

What is now confusing is that when we use a custom rom (ARHD, LeeDroid etc) we have a boot.img file to flash via fastboot and there is also one with the Bricked-Kernel. Are they the same, different is the order of flashing important.

Please can we some further clarification. Thank you

The ramdisk I build the boot.img with should work on every rom, except your rom dev has done some fancy stuff with the ramdisk. If you want to be sure: extract the boot.img from bricked and the one from your rom, and just copy over the kernel (zImage) from bricked to your roms extracted boot.img (thus overwriting the stock kernel) and repack everything
Quote:
Originally Posted by auras76

Hi, I wanted to integrate it into my rom with your permission, thanks

Go ahead
Quote:
Originally Posted by mgmCube

I would like to disable the power button.

I tried a couple things in qwerty.kl and generic.kl. But it also breaks the swipe2wake function.
Does anyone know how to disable the power button and let the rest function normal?

Can only be done within the kernel and I would not recommend that atm. Sweep2wake can't wake your phone from hibernation (htc's "quick boot" feature) atm.
Quote:
Originally Posted by miniterror

hey show,
In aroma it says disabling the screenshot feature with power+home but that still works for me.
Think something is going wrong there

Yeah I borked something... it was way too early
The Following 9 Users Say Thank You to show-p1984 For This Useful Post: [ View ]