On youtube I get a message saying I have an old version of Adobe's Flash player

I didn't have any flash player installed before this one?

Maybe it doesn't work in Opera 8.65?? Is it only for v9.5???