Default [DISCONTINUED][CWM][ALL BL][STOCK] ClockWorkMod 6.0.4.6 for Xperia T/TL/TX/V v9

This thread is no longer continued. My T died a few weeks ago for second time in his life and there is no cheap repair. I see you in the LG G2 forums (current device)


CLOCKWORKMOD FOR XPERIA T/TL/TX/V v9

From v1 to v8: based on this, so most credits go to cray_Doze.
From v9 onwards: own development.


This is for:
  • Rooted phones
  • Locked/Unlocked bootloaders
  • Stock firmwares T/TL/TX/V (ICS & JB)

What is working:
  • Backup
  • Restore
  • External SD
  • Flash zip files
  • Mount/Unmount partitions
  • And so on, so apparently all (further testing and feedback will be appreciated)

What is NOT working:

Some users are reporting issues on latest v9 like error mounting both system partition and usb storage, formating external sd, and others. Take in account that CWM 6.0.4.6 is the latest version available for our devices, as many of you are requesting repeatedly. It comes from CM10.1, which is Android 4.3 while most of us are still on 4.1. So a lot of things are expected to not work. While Android 4.3 finally arrives for our devices and these issues are solved, if you're experiencing problems downgrade to v8 which is fully functional. Simple and clear.


Installing:

Installing CWM for the first time is as simple as:

Flashing CWM from itself (could be required after flash a rom) is as simple as:

Older versions can be found here.


Entering CWM:
  • Disconnect usb cable and power off the phone
  • Power on the phone
  • When SONY logo appears:
    • On Xperia T/TL/TX press repeatedly (not holding) volume-down button until the phone vibrates
    • On Xperia V running ICS press repeatedly (not holding) volume-down button until the phone vibrates
    • On Xperia V running JB try one of these:
      • Press repeatedly (not holding) power button until the phone vibrates
      • Tap repeatedly the screen
  • Wait a few seconds and you will be on CWM

Navigating CWM:
  • Volume+ for up
  • Volume- for down
  • Power button for enter/ok

Unable to enter recovery?

Make sure you have granted superuser permissions to adb shell. Sometimes this occurs when running install.bat/install.sh for the first time, sometimes not. Best way is open a command terminal on your favourite operative system, enter "adb shell" and then enter "su". Your super user application will ask you for grant permissions, accept and retry running install.bat/install.sh.


Changelog:
  • v1: Modified sh script (removed some unnecessary commands, added validations with messages for install success/failed)
  • v2: Modified binary to display correct model information and versioning
  • v3: Tweaked chargemon script for JB kernels compatibility (many thanks to TiMiN8R for provide this solution)
  • v4: Reboot Fix self-integrated
  • v5: Tweaked chargemon script for Xperia V 9.1.A.1.140 firmware compatibility (many thanks to cray_Doze for provide this solution)
  • v6: Updated to CWM 6.0.3.0, solved wrong backup time
  • v7: Copy proper charger file for every supported Xperia model (installer version will ask for model whereas flashable version will try to determine it based on ro.semc.product.model build.prop property)
  • v8: Added install.sh script to allow installation from Linux environments (just applies to installer version, but flashable version also upgrades to do not embroil versioning)
  • v9: Updated to CWM 6.0.4.6

Bug reporting:

If you found a bug, or this CWM is not working for you, please send me a PM with:
  • A description of your problem
  • Which version of CWM you are
  • Which version of Android you are
  • Which model of Xperia you own
  • Dropbox links (or similar) to download the following log files (you must pull off from your phone just after reproduce the error):
    • /cache/chargemon/chargemon.log
    • /cache/recovery/last_log

If you help me, I will be able to help you. If your sole intention is to post something like "this doesn't work" or "please repair" and nothing more, your post will be ignored (at least by myself).

Last but not least, say that I just own the Xpertia T, not the TL/TX/V. That just means one thing: tracking and solving bugs on these are, as little, very difficult. Be patient and trust on hard work of developers.


Important notes:
  • Some users are experiencing problems entering CWM when they upgrade root's integrated busybox (1.20.0 version) to a mayor version (many thanks to istux for report this issue). Try reinstalling CWM to fix (many thanks to devilmaycry2020 to provide this solution).
  • If you come from ROM-integrated CWM, chances are that you do not have the proper charger file for your device model (it is copied on CWM installation, but no one has been performed due the integration nature). So if you are suffering automatic power on when charging, you must reinstall CWM.


Enjoy it!