Is there any method for Mac-Users to force the update?