While I agree with your intent I think devs should just specify which version works in their title, this works for most phones that have multiple models.