Quote:
Originally Posted by ssj5trunks View Post
I think the problem is when i read registry.
I do that for block screen for not go in stand by mode.

Check these registry if you have it:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Power\Timeouts\BattSuspendTimeout
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Power\Timeouts\BattSuspendTimeoutSave
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Power\Timeouts\ACSuspendTimeout
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Power\Timeouts\ACSuspendTimeoutSave
HKEY_CURRENT_USER\ControlPanel\Backlight\BatteryTi meout
HKEY_CURRENT_USER\ControlPanel\Backlight\BatteryTi meoutUnchecked
HKEY_CURRENT_USER\ControlPanel\Backlight\ACTimeout
HKEY_CURRENT_USER\ControlPanel\Backlight\ACTimeout Unchecked

If you dont have these registry it is a problem i correct it in the next version, if i dont find it i set it to 0.

I think your problem is that i cant find any of these registry key and return error.

Bye
On my Asus p535 with WM 6.5 and Asus WM p525 with WM 6.1 do not work.
I did that you wrote. And changed values HKEY_CURRENT_USER\ControlPanel\Backlight\BatteryTi meoutUnchecked to 0 and HKEY_CURRENT_USER\ControlPanel\Backlight\ACTimeout Unchecked to 0 too.
All other values were 0.
I am thought that problem in .Net FW 3.5.