Or Continue to Thread: [Kitkat][Nightlies] CM11 Andro…
Find Your Device:
11th November 2013, 09:15 AM
overclockthesun's Avatar
Senior Member
Flag Mumbai (Bombay)
Thanks Meter: 270
 
423 posts
Join Date:Joined: Jul 2011
More
Quote:
Originally Posted by nastys

I found a workaround for the apps. Enable root access in File manager, put the One Mobile Market Apk to /data/app and set permissions to rw-r-r, then reboot. Open the market, enable root install in settings, install ES File Explorer, open it and enable APK root install as well. Now you can install APKs

I tried to enable ART runtime, but it boots forever. I coulnd't odex it using the universal script. It tells me I have no free space in system

Also I used a vCard file to copy my contacts.

I can confirm this method. I just went a step further.... and installed Google Play Store and Titanium backup too. @Quarx @Blechd0se @TJKV Apparently, it seems that we cannot install apks for 2 reasons:

1) We need to be able to at least put an app into the /data/app folder or /priv-app folder. Unless we copy the apk here nothing works.

2) More important than number 1..... We have to change permissions of the apk to rw-r-r. For obvious reasons we can't change permissions on the SD card. So you have to copy over apk to internal memory.

Our "parsing error" seems to be permissions related?

Now, I installed Titanium backup and viola!!!! it worked....same goes for Google play store whats even better is that I started restoring my apps with Titanium and everything is restoring. I just setup Whatsapp and the rest is still restoring. Once its done, I will be back a further report on my progress.
No need for ES file manager ....jsut copy over titanium and google play store to /data/app and /priv-app respectively and it works ....even copying play store to /system/apps works as long as the permissoins are rw-r-r..

If this works, @Quarx you can count me in to run this build as my daily driver no matter what the hiccupps are



---------- Post added at 01:45 PM ---------- Previous post was at 01:43 PM ----------

Quote:
Originally Posted by Fotogravin

No, TWRP doesn't give an error if /system is full. With CM11 I couldn't get all gapps to work, it even broke stuff that worked without flashing gapps. So I flashed AOSP (2.6-kernel) with core-gapps and that is ok. Even with Play Store and stuff.

Yup took me a while to realise that. I am on CM11 now...look at my post above.... did not use gapps...I have the apks for all 4.4 apps deodexed from a link on xda. I am restoring my titanium backup right now....so far so good youtube has installed to.
Fix for the black screen with status bar. Just let your screen go to sleep, wait for about a minute before you press the power button to unlock and it will start. I had the black screen again today morning, said to hell with it...left it the way it was and had breakfast. When I checked after that it started working properly!
Last edited by overclockthesun; 11th November 2013 at 09:39 AM.
The Following 2 Users Say Thank You to overclockthesun For This Useful Post: [ View ]