Or Continue to Thread: [How to Video] Manually update…
Find Your Device:
15th November 2013, 05:30 AM   |  #26  
Member
Thanks Meter: 11
 
34 posts
Join Date:Joined: Aug 2011
Quote:
Originally Posted by Geese1

Still not having any luck. I can sideload the file onto the tablet fine, but when it gets to the "Verifying current system" stage I get an error saying:

"/system/app/BasicDreams.apk" has unexpected contents
E:Error in /tmp/update.zip
(Status 7)
Installation aborted

I've tried this several times and keep getting the same result. I'm rooted, but running the stock kernel and rom, and using the stock recovery. Any help on this would be greatly appreciated.

I was in the same situation and ran into that issue as well. What I did was download the 4.3 factory image from here: https://developers.google.com/androi...s/images?hl=vi

Make sure you get the correct one for your device. I have a 2013 wifi so I chose: Android 4.3 (JSS15R)

Inside that downloaded file, you'll find image-razor-jss15r.zip. It's a couple of levels down. Unzip the files from there to your SDK folder (should be boot.img, recovery.img, system.img, userdata.img, and cache.img).

Boot your Nexus 7 to the bootloader (volume down + power) and connect to your PC with USB cable. Do NOT go into Recovery mode yet.

From the command prompt, make sure you can see your device: fastboot devices

Then, run the following commands:

fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot erase system
fastboot flash system system.img

At this point you have a clean install of 4.3 JSS15R.

Now go to Recovery mode and sideload the 4.4 OTA as you originally tried and it should work this time.

I followed these steps and was able to update to 4.4 without losing any data. YMMV
The Following 8 Users Say Thank You to superblast For This Useful Post: [ View ]