Question [Q] [Help] No cell service after wipe

Hello,

This is going to be kinda long, I want to give all details I can remember in case it helps.

I decided this morning that I was going to try out the unofficial CM11 rom for Galaxy Nexus GSM. So, first thing I do is a backup from Clockwork Recovery (latest touch recovery flashed).

After that, I flash the rom, and the gapps. I reboot to see if it works, and after 5 minutes of use everything looks pretty sucessful.

So, adb pull my backup and offload it to my computer in the case that something goes really wrong, because I'd like to get a clean start. So, I wipe the device as completely as I can in Clockworkmod Recovery. I then adb push the cm11 rom and the gapps roms referenced above. I use Clockworkmod Recovery to flash those onto the device, reboot and start playing around then realize that I have no cell service. Try manually registering on my T-mobile to no avail.

I think this is a baseband problem, so I fastboot flash radio (stock nexus radio rom from 4.3), reboot into the system and still no service.

Then I begin thinking my phone radio has completely failed, so I take a simcard from my girlfriend's phone pop it into mine, reboot and still no service. Reinstall my original sim card.

Then I am REALLY thinking my radio has failed, so I figure I'll just flash the full 4.3 stock suite in case I'm missing something small because I don't understand how something works. Still no service.

So, as a last resort, I push the Clockworkmod Recovery backup back into the /sdcard/0 directory, restore in Clockworkmod Recovery, reboot and it works(!).

Now I start wondering what I'm failing to understand about this problem, so I go ahead and do a factory reset in Clockworkmod Recovery and back to no service(!).

I really thought I understood how it worked, but I must be missing something here, or maybe Clockworkmod Recovery is wiping something it shouldn't be? The final thing I can add is each time I fail to get service in the installation, the service bars light up for 1/2 second to 2 seconds during boot. Maybe someone could help me spitball what's happening here?

Thank you very much in advance.