Default [Q] Stuck on bootanimation. HELP

Tried looking everywhere, but couldn't really find anything. Any help is appreciated!

Alright some background info

I rooted my phone and unlocked the bootloader successfully. I wanted to do more, so I flashed TWRP onto my phone using JRummy's ROM Installer. I followed all the steps and successfully booted into TWRP recovery. I created a Nandroid backup and when I tried rebooting my phone it gets stuck on the 4G LTE boot animation.
I then tried wiping the cache etc. and restoring the backup I had just created. To no avail, the phone kept getting stuck on the boot animation. I've tried restoring the backup multiple times with no success.
On my last attempt I checked another box on the TWRP restore page, I think it was the VG5 verification or something. Halfway through what I though was going to be a successful restore, my phone reset and got stuck in the boot animation again. Now when I boot into recovery it's the stock recovery, not the custom TWRP as before. Tried clearing everything/factory reset and it still stuck on boot animation.

As a college student I'd like to get this figured out as soon as possible (hopefully before midweek, Friday at latest). If I can figure this out with your help I'll be very grateful.
If I can't find any other way, I'm willing to flash stock back using ODIN and seeing how that turns out. Also my home button is a little sticky so I doubt the Verizon worker would be able to boot into recovery or download mode.

Any suggestions?

For those of you TL;DR
1) Rooted phone / unlocked bootloader
2) Flashed custom TWRP recovery onto phone
3) Created a Nandroid backup from recovery
4) Tried rebooting and gets stuck on 4G LTE boot animation screen
5)Wiped cache etc. and retried multiple times. Doesn't work


EDIT: I flashed stock through ODIN and everything seems to be in order. I'll be trying to root and recover everything through TWRP again and if it doesn't work oh well. My end goal is to have a custom ROM