Default [Q] EVGA Tegra Note 7 root?

EDIT:
Go here to root your Tegra Note 7: https://github.com/linux-shield/shie...ster/README.md (thanks to CampGareth for finding the link).
I have tested this, it works with no bloatware, only installs SuperSu.

---------
Hey guys, I got my new Tegra Note 7 last night and I've been trying to get it rooted, but I keep running into trouble.
First of all, I DO NOT want to use some shady Chinese software that installs a bunch of bloat on both my tablet and PC just to get SuperSu going, I've tried that method and had to reset the tablet to get rid of all the crap it installs (and it didn't even seem to root anyway).

Now I'm trying the manual method from here: http://pan.baidu.com/wap/link?uk=307...426036&third=0
Which, again, is Chinese but at least I can see what it's doing since I'm issuing ADB commands, and supposedly it has worked for others on this forum.

Now, I get to step 3 on the included PDF which says to boot an insecure bootloader image with "fastboot boot tegranote_insecure_boot.img", I do this and the tablet screen flashes a few times and reboots to android.
I get to the next step which says to open an adb shell, and do "/sbin/rootsh +p" to get a temp root shell, and this is where I get stuck. Instead of getting a root shell I get the message "/system/bin/sh: /sbin/rootsh: not found". Does anyone have suggestions?

By the way we really need a Tegra Note 7 subforum here at XDA, if the mods could add it that would be great.
Nexus 4 - CM10.2
EVGA Tegra Note 7 - stock fw, rooted