Default [Q] Stuck in HBOOT/FASTBOOT Menu

Hey guys,

So randomly my phone decided to just turn off (it was just idle on the home screen) and when I booted it back up it was in the Fastboot Menu.
I've tried reboot and even factory reset but neither work they just bring the phone right back to this when I turn it on anyone got any tips for me I'm hoping there's a really simple solution I have naively overlooked.

The screen says

***LOCKED*****
***Security Warning*******
VIVO PVT SHIP S-ON RL
HBOOT-2.03.0000
RADIO-3831.19.00.19_M
eMMC-boot

A few months back I used a RUU to manually update to ICS and everything went fine and I had been running it fine for a long time so I'm not sure if that impacted on this in any way at all.

Anyway since this happened I've tried the old turning it off and on, battery out for an hour, sim out/sd out etc

Also the following:

I've tried running the RUU again but I get error 170 as it gets stuck at "waiting for bootloader" after it reboots the phone at the start of the process
(Tried in all my USB ports, reinstalling drivers/HTC Sync, using original cable)

I tried flashing from my SD card, it reads the zip and asks would you like to update but after I click yes it goes for a few seconds and then says "Partition Update Failed" and prompts me to reboot. (Tried multiple sd's)

I tried to unlock the phone using the HTCDev unlock, however once I get my token and use it to get to the unlock screen on the phone I am unable to select yes my phone simply does not acknowledge the option when I press the power button it instead vibrates a few times and then inevitably I end up selecting the No option after much frustration.

I should probably mention that fastboot lists my device under devices but adb does not.

I would have tried making a goldcard but I currently cannot obtain my CID through adb nor by using readcid.exe with my laptop card reader.

So if anyone could help me out that would be much appreciated as I don't have a warranty on this or anything and HTC support were of exceedingly little help.