Exclamation No cellular/data on 4.4 roms


Preface, I'm currently using Jedi Master 16 / Android 4.1.2. I have not tested anything newer than this so this problem COULD potentially exist for 4.2 & 4.3 as well, but I have tried skipping directly to 4.4.

So far I have tried both Omni & SlimKat. In either case, after booting I have no cellular/data service and am unable to search for networks. When viewing the status info on the phone, my IMEI and Baseband versions show as "unknown", see attachment.

I have tried the two latest modems (including the new 4.3 modem) from both here and here.
I have tried using the 4.3/4.4 compatible DevilKernel2 as a solution as advised here.
I have tried flashing from both the latest CWM and TWRP (with selinux / 4.4 support).
I have tried toggling selinux to passive mode using this app, with all kernels.
I am on the old 4.1.2 bootloader with no Knox.

Restoring to 4.1.2 roms works fine, it is not a corrupt EFS like the symptoms may seem to indicate.
I am running out of possibilities, at this point the only thing I can think of is an incompatible bootloader version, though I would assume devilkernel would resolve the issue if that was the cause.
Anything else I am possibly missing?

Official t-mobile 4.3 update (root/no knox) works fine, so it seems isolated to 4.4+ roms.

After installing the official 4.3 update I was able to perform a full wipe and update again to 4.4 roms, after which they worked just fine.
Attached Thumbnails
Click image for larger version

Name:	rqnt7gM.png
Views:	493
Size:	71.3 KB
ID:	2451058