On a first thought, you need to get back to the original kernel.
Update from 4.4.1 to .4.4.2. has no problems with different kernels installed, however this won't work from 4.4. to 4.4.2.
The exact error message would be also helpful