Default [Q] "Starting Apps" Frozen boot

Ok

i am at a loss I have my mates nexus 4 (vanilla no root locked bootloader) just OTA updated to 4.4.2 stuck on Android is upgrading Starting apps two hours on that screen powered down reboot and boot loop from there in

So thinking i could rescue with a little trickery i took it home ...so far i have these results

tried wipe cache and factory reset from Google standard recovery ... nothing

installed CWM wiped everything (cache dalvik system data) .. nothing

gave up flashed factory google image (4.4.2) from bootloader ... same "starting apps" freeze again, reboot to recovery wiped everything then boot looped on trying a reboot
"
flashed factory image 4.4 same results boots once locks on starting apps then bootloop every boot after then

flashed 4.1 factory image (earliest build) ... Success got it to load everything working .. yay

OTA update came through to i think 4.1.3 that worked

OTA for 4.2.2 just installed and back to Android is upgrading "starting apps" and frozen there now for half hour

this is a clean install every inch of the phone has been completely reset no apps other than factory google apps are installed can someone PLEASE give me some advice im at a loss.

thanks guys

Myxin