Default Cyanogen-11 stuck while booting (yes, I googled)

Hi, everybody!
I am stuck with the problem, I cannot solve, and cannot google.
I saw a lot of similar, but none of the directions helped me to fix my phone.

I've got my Nexus 4 which was a great phone until I updated it to 4.3, some of the screen portions became senseless on some applications (starting from SMS, to some game apps).

I was suggested to downgrade or change ROM, which I am trying to figure out right now.

I've rooted my phone with SuperSU-v1.85 and installed Clockwork-6.0.4.3.
Once I've done it, I was trying to load an images of cm-11 and gapps-4.4 with
adb push
it finished all operations in cmd, however, I got
E: Can't mount /sdcard

Thus, I've tried to install all zips from sideload and my cmd.

I didn't touch kernel.

Once I've done this, I tried to reboot, but Cyanogen stuck, running circles.
I've tried to do factory reset, clear cache and dalvik, however none of those worked.

I also have been doing this with a more stable release (cm-10.2.0), but I got same thing.