Unhappy [Q] Can't Enter Into Recovery Mode Galaxy S4 AT&T

Hello,

I think I just did something really dumb!

I just recently got a Samsung Galaxy S4 {AT&T}, and I was able to root it just fine. Today, I thought I'd try installing the Gummy Rom. That worked out just fine as well. Whenever I tried to install gapps, however, it said the install failed. To be safe, I decided to reboot from a previous backup I had made. Unfortunately, I got stuck at the AT&T logo when rebooting. I read somewhere that the solution is to remove the battery, place it back in after about five minutes {to be safe}, and then power into recovery mode.

My problem comes here.

I can't get into recovery mode. I've tried multiple times by powering on the device while holding Volume Up + Home + Power. Then, when I see the Samsung logo, I let go of the power button while still pressing the volume up + home buttons. Normally, I would get into Recovery Mode. However, now all I see is a quick flash of "Recovery Rebooting..." in blue at the top left, which brings me straight back to the AT&T logo screen problem.

Help?