Default [Q] External SD not working after custom ROM install...

I'm relatively new to this but up until now I've had no problems so far... So I just upgraded to the latest version of Jamal's 4.4.2, following the proper install method, clearing data and caches in CWM.

I DL'd Titanium Backup and tried to change my backup location to where I store my apps which is on my SD however upon selecting /extsdcard it says that 'this folder is not writable'. Using a file manager and attempting to access external just displays an empty folder. However, going into settings-storage shows that the SD card is mounted and displays the correct size/available space.

If I unmount then mount the card it seems to function again, I am able to access the files in a file manager. That is until I go back into Titanium Backup. Now it does something different here if I press 'DETECT!', it finds my backups and displays the correct amount and path on the external however upon selecting them it takes me to the appropriate folder and says 'This folder is not writable' and 'this folder is empty.' and Use the current folder' is greyed out. The external sd is then back to displaying nothing in the file managers again.

I've tried wiping and re-installing the ROM, but it still carries on doing the same thing. I've searched in the ROM's thread and other places and I haven't been able to come up with any solution so I'd be grateful if you could shed some light into this issue and possibly offer a potential fix?