Default [Q] Bricked hardware or system?

Hi.

I have a Galaxy S2 i9100 running Resurrection Remix 4.0.7 (as well as its previous releases for the last couple of years).

While connected to my laptop (Win7 SP1 x64), I transferred a few files over to the phone and let it there.
When, later, I tried to transfer an extra file, the Explorer's transfer popup became unresponsive, as well as any new Explorer windows that included the phone (e.g. 'my computer'). Disconnecting the phone, let those windows open up.

I disconnected the phone and rebooted it.
It got to the RR animation logo and stayed there for over an hour. Removing the battery and restarting, had the same results.

I went into download mode to see if it's working, it did, and then I went into Recovery mode and tried to clean the cache.
It gave me this scary looking result:

CWM-based Recovery v6.0.3.6
E: Can't mount cache/recovery/command
warning: No file_contexts
E: Can't mount /cache/recovery/log
E: Can't open /cache/recovery/log
E: Can't mount /cache/recovery/last_log
E: Can't open /cache/recovery/last_log

-- Wiping cache...
Formatting cache completed

It stuck there so I restarted the phone.
No response at all from now on. Just a black screen.
No download/recovery mode, no identification when connected to the USB (by Windows itself or Odin), ADB finds no devices, the jig I got from eBay gets no response (unless I don't use it properly or maybe it's not applicable to JB systems as I seem to remember).

The phone looks like it's bricked for all intents and purposes.

So what happened? How did it get bricked?
Was it its time to do that (2 year old phone), or something I did?
Is there any possibility to restore it (I can't afford to buy a replacement nowadays).

Thanks much for any help.

P.S. I posted a similar message to the RR forum in case they have some way to get to the OS and fix something, but the problem looks generic and I might get more suggestions here. Sorry for the (almost) double post.