Or Continue to Thread: Nexus 5 with dead flash memory…
Find Your Device:
30th January 2014, 04:12 AM   |  #1  
OP Senior Member
Thanks Meter: 168
 
575 posts
Join Date:Joined: Jul 2011
I went to use my Nexus 5 (D821) earlier today but it wouldn't turn on. Holding power didn't seem to work, so I assumed the battery was flat and left it charging for a couple of hours. Now it gets stuck at the first black and white "google" logo forever. The device is unlocked and rooted, but was working fine, and nothing was changed leading up to the issue.

I'm able to access the bootloader and fastboot still, but nothing seems to work.

Attempting to flash a partition (fastboot flash recovery twrp.img):

FAILED (remote: flash write failure)

Attempting to erase a partition (fastboot erase userdata):

FAILED (remote: failed to erase partition)

I can boot TWRP by running fastboot boot twrp.img, but attempting to mount any partitions results in errors such as:

E: Unable to find partition size for /system
E: Unable to mount /system

Also, attempting to install a zip shows that internal storage is 0MB in size.

At this stage, I suspect the flash memory has died a horrible death, and I'm trying to work out how to set the tampered and unlocked flags back to false to I can return it under warranty, however this is proving difficult too. If I run 'fastboot oem lock', it appears to succeed (the bootloader even changes to 'LOCK STATE - locked'), but as soon as I reboot the device, it reverts back to unlocked, and the padlock shows up again.

I've even tried manually via:

echo -ne "\x00" | dd obs=1 count=1 seek=16400 of=/dev/block/platform/msm_sdcc.1/by-name/misc
echo -ne "\x00" | dd obs=1 count=1 seek=16404 of=/dev/block/platform/msm_sdcc.1/by-name/misc

but these don't seem to have any effect on the flags.

So now I'm out of ideas, and just hoping I can set these flags back before sending the device for warranty. Any ideas?