Exclamation [Q] Stuck on Samsung logo & yellow triangle disappeared????

Hello everyone!

So something weird happened today. My S2 (that was running Avatar ROM jellybean but forgot which version) got a little wet. Just some sprinkle but did get under the battery cover so I dried it off and everything. I booted up my phone but to my surprise the yellow triangle disappeared. It still booted normally and the phone worked perfectly fine.

I then decided to upgrade my rom to the newest kitkat that Avatar had. I did that OTA and installed it. It rebooted itself and it worked fine until I had multiple FCs. So I decided to restart my phone but it never got past the white Samsung logo at the beginning (still no yellow triangle).

I went into recovery mode, wiped cache and dalvik cache, reinstalled the update but still couldn't get past the Samsung logo.

I googled around and some people said to reflash a rom that worked before the problem started so I did just that. Still stuck on Samsung logo.

I'm out of ideas now. Anyone know or can suggest something that I can do?

Thanks in advance!!!