Find Your Device:
Or Continue to Thread: Unable to save pictures or scr…
30th January 2014, 05:37 AM |#1  
OP Junior Member
Thanks Meter: 0
tl;dr: I cannot save pictures or screenshots on my phone, as well as a few other small quirks, can someone help?

Hello XDA, I've just recently encountered a strange issue with my Nexus 5 and I was hoping one of you might be able to help me out. I'd like to have screenshots to break up the text wall, but due to the nature of my issue, that's out of the question.

So my big problem started about two days ago, when I wanted to flash the omnirom nightly (1/27 to be exact) to my phone.

While doing the factory reset before flashing the rom, TWRP got stuck (and I'm talking about 10 minutes) formatting /data not including internal media. I was left with no choice but to hold volume down and power and hope for the best. This is what I bet screwed things up. After that I tried again, and the formatting worked, and omnirom booted, but with the error message of something about device UIDs being inconsistent and recommending I format my data partition.

Well since the rom was a nightly, I felt like ignoring the message, but I did notice issues: I could install and uninstall apps, but none of them could really access the internal storage (for example, any attempts to save a picture, like through chrome, would fail. I also couldn't restore from titanium backup. Connecting to my pc would not display my files).

Dismayed, I obeyed the message and did a full wipe of the data partition and tried again (not just the factory reset one, but the full wipe of /data, and don't worry, I could still backup using ADB pull so I haven't lost anything). This caused the UID error message to go away but I still had issues-not as bad as before-but still issues. Titanium backup worked, so I used that to restore successfully, but I couldn't make new backups. I was frustrated and blamed my issues on using a nightly so I did another full reset and went back to stock.

Now, I wasn't given another UID message, and ALMOST everything works, but I am left with the issue that is the reason I post this thread. I can't take pictures, video, or screenshots and a select few apps fail to recognize the internal sd card (reddit sync, for example, will fail to save pictures when I try to download them, but other apps, like chrome, will succeed to do so, so it is a non-issue. I could also connect to pc again, yay!).

The camera (app and hardware) will still work, and I can tell it takes the picture because the little thumbnail that slides to the side after taking a picture appears. It just fails to save the picture. When I swipe to view the picture, it shows up only as a dark gray box. If I view it in the photos app, I am greeted with the message "media not found." When I try to take videos, Camera will force close the moment I press record.

I've tried a few things, like clearing the camera's data, but that was unsuccessful. Different camera apps (I tried Focal) result in the same problem. Using the Root File Browser app, I also made sure that permissions weren't locking access to that folder. I've also tried deleting the DCIM folder by connecting to PC and then taking another picture, but that still did nothing.

I don't know what else I could do besides another /data format, but I already did that and I don't feel like another format would really do anything since I already did one. I'm left with little that I could think would fix this, but I'm sure someone here could help me.

It is late now and I have school in the morning, so I'll check back on this thread in about 16 or so hours when I'm done with that. Then if anyone has a potential fix, I could try it. If I don't see a fix, I could post a video describing my problem or any more information you might find useful. Thank you all and goodnight.