Or Continue to Thread: [Q] SII (Vodafone NL) with &qu…
Find Your Device:
14th February 2014, 01:36 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Feb 2014
Hi all,

I have a SGS II from Vodafone NL that was not vendor locked, unfortunately I don't know more about it as I didn't care about firmware, kernel and the such. The phone is 2y 9m old. It all started with a low battery reboot, battery was at 0% and while plugged in was restarting shortly after boot, some too demanding applications that wanted to do their thing immediately after boot. This happen 2 or 3 times, on one of the boots I saw the android updated (green robot with spinning mesh), it was really short and I recall something about updating one file or so. Didn't pay much attention, the phone booted up properly when the battery reached 1%. After a few hours in which I used the phone a few times I found the phone shutdown and on boot I had the boot logo loop. Not knowing what to do I went into "Recovery mode" (Vol up + Home + Power) and issued a factory reset. It did something and I didn't pay much attention to it. There were a lot of errors related to /system /cache and something else that was not accessible. I was thinking that the on-board emmc might have died or at least part of it is. After the factory reset the phone has only the battery logo and "Download mode" (Vol down + Home + Power) only. I don't know what kernel I had nor what OS version it was on, I've updated via Kies some time ago, autumn 2013 maybe.

I've downloaded from sammobile:
I9100BULPG_I9100VDFLP9_I9100BULP8_HOME.tar.md5 Feb 2013 Ver 4.1.2
I9100BULPG_I9100VDFLP9_I9100BULP8_HOME.tar.md5 Sep 2012 Ver 4.0.3

When trying to upload them with Odin 1.85, 3.04 and 3.07 they fail at "NAND Write Start!!" with no other error message, just the normal succeed 0 / fail 1 which I find kinda dumb. Tell me what the error was, the device surely has said something or it timed out. I've tried this on 2 different computers both with Windows7.

After all this failed I tried flashing:
Siyah-s2-v4.1.5.tar

Same error from Odin but something changed in the "Download mode", now it says "CUSTOM BINARY DOWNLOAD: YES (1 counts)", before it was 0. The current binary is still saying Samsung official. The phone is still not booting and the "recovery mode" is still not there.

My questions:

Is there any way I can connect to it via adb and maybe have a shot at looking at it's disk layer? Saw that dd can be used within the adb shell IIRC. I do have some linux/unix filesystem recovery experience.
I saw that they use the .PIT file to change the sector allocation and avoid the damaged parts of the emmc. In order to do that I need to somehow give it a booting kernel. Is there any way of doing that? Maybe boot another device that can attach the emmc.
Should I try heimdall? Can it connect to the device even in "download mode"? I need to install one linux machine for this as I have only windows and BSDs around.
Is there any way for me to reliably find out the model of phone I have?
Are there any other things I can try to recover it or can I consider it's emmc dead?

Thank you.
Last edited by andrei693; 14th February 2014 at 01:50 PM.